User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: dash board/ dials not working??? :(

  1. #1
    New Member
    Join Date
    Feb 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry dash board/ dials not working??? :(

    hello, posting on behalf of a colleage who has a 2007 Vectra estate 1.9 cdti.


    interimttently, the dash dispaly (dials and warning lights) switch off/goes blank. everything else seeem sto continue working ok.

    remedy seem to be switch off and restart.

    length of time seem to be totally variable.


    any suggestions/fixes????

    local dealer-stealer is being very unhelpful and evasive.....

    any help gratefully recevied..... as they have two young children and his missues is now too scared to drive it!



    thanks in advance


    Dan

  2. #2
    Regular Member
    Join Date
    Jan 2010
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had the same problem with mine. Theres a thread on here about it somewhere. If you open the front passenger door, you'll find a fuse board, there are two fuses which need to be looked at (I can't remember their numbers), I just removed them both and re-inserted them and this cured the fault. On the other hand, others with the same fault have had to replace the CIM and they ain't cheap.

  3. #3
    Regular Member
    Join Date
    Jan 2010
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The fuse numbers are 17 & 26, also worth checking/cleaning the ABS plug (under the bonnet)

  4. #4
    Regular Member si_hoss's Avatar
    Join Date
    Apr 2009
    Location
    Stevenage, Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah try the fuses in the dash, think it's # 17 & 26 (check that first) and re-seat all the blue one's in the fuse box in the boot. Other thing is to spray contact cleaner on the ABS plug contacts under the bonnet, and finally clean the contacts on the plug on the CIM itself.

    If you do all this and like me it still doesn't cure it, then you'll need a new CIM which aren't cheap as mentioned. Think it's approx £400 for CIM and a tech2 session at whatever the going rate is.

    I've lived with mine for 18months now, still annoying but that's life

  5. #5
    Regular Member bothyboy's Avatar
    Join Date
    Nov 2009
    Location
    Herefordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had this once (thankfully) cleaned fuses mentioned and not seen it again. But still concerned it could return.

  6. #6
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Fuses 17 and 26 infer an adverse problem linked to the Body Control Module.

    The actual fuse for the CIM module is Fuse 10.

    I always quote a whole rake of fuses to check as follows

    Fuses 7, 9, 10, 12, 17, 19 and 26.

    The other common cures have been

    1) check that all the steering collumn earth tags are secure and in good order

    2) Check and clean the pins in the ABS module connector plug

  7. #7
    New Member
    Join Date
    Feb 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks everyone! will pass on info

    Dan

  8. #8
    New Member
    Join Date
    Feb 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well..... hes just spoken to the garage, who reckon its the dash cluster.... and want £500 to replace and tech2 it!

    and.... best of all.... its not covered by his warranty

  9. #9
    Regular Member si_hoss's Avatar
    Join Date
    Apr 2009
    Location
    Stevenage, Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Robsey View Post

    1) check that all the steering collumn earth tags are secure and in good order
    I remember reading on here that someone had cured theirs by running a separate earth lead from the CIM. I really should try this to see what happens.

  10. #10
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    265 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Quote Originally Posted by dankilbourn View Post
    well..... hes just spoken to the garage, who reckon its the dash cluster.... and want £500 to replace and tech2 it!

    and.... best of all.... its not covered by his warranty

    depending on where you are in essex, IF it does need a new set of clocks, it should be no more than about £200 all in
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dials not working!!
    By kev.whitehead in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 5th May 2012, 17:14
  2. Instrument Panel Dials Not Working
    By mick mcm in forum Electrical & ICE (including SatNav)
    Replies: 27
    Last Post: 18th November 2010, 15:13
  3. dash board.
    By delboy2028 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 18th March 2010, 20:22
  4. Dash Dials keep going off !
    By bart1664 in forum Electrical & ICE (including SatNav)
    Replies: 23
    Last Post: 24th October 2009, 18:34
  5. Dash dials at 0
    By Tigger in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 8th June 2009, 20:27

Visitors found this page by searching for:

vauxhall insignia dashboard not working

vectra c dash lights not working

vauxhall vectra instrument panel not working

vectra c instrument panel not working

vectra dashboard failure

vectra c dashboard not working

vauxhall vectra dashboard lights not working

vauxhall vectra dash lights not working

vectra c clocks not working

vauxhall signum dashboard not working

vectra dashboard not working

vectra c dials not working

vectra instrument panel not working

vectra instrument cluster not working

vauxhall vectra 2006 dashboard lights

vectra c dash not workinghttps:www.vectra-c.comforumshowthread.php146373-dash-board-dials-not-working-(vauxhall vectra 150 sri no dash lights or dailsvectra c no dash lightsvauxhall vectra dash not workingvectra c instrument cluster not workingvauxhall vectra c dash not workingholden vectra dashboard problemsvectra c dashboard fusevectra c dash problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •