User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Power Steering light

  1. #1
    Regular Member GoldenWonder's Avatar
    Join Date
    Dec 2007
    Location
    Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power Steering light

    I was turning around in a car park tonight (on full lock turning left) when the steering went very heavy and the warning light came on (steering wheel with exclamation mark)

    I sat for a minute but it wouldn't come back so I restarted the car and everything was fine. I've had the car 3 months and this has never happened before. The manual just says the usual 'take to a Vx dealer' but is this something thats likely to get worse?

    I've searched here and it looks like a steering column or CIM (?) and judging by the cost of those the car would have to go - its a 2006 1.8 VVTI and spending £500 upwards just isn't cost effective for me!

    Its just had the front exhaust pipe replaced today as well - theres nothing linked there is there!?
    Last edited by GoldenWonder; 30th August 2011 at 21:21.

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    First thing to do is check the fluid level.

    Also don't forget, on full lock you're putting extra strain on the pump. Best practice is to back off the steering slightly when you hear the noise of the pump changing.

  3. #3
    Regular Member Ademusic's Avatar
    Join Date
    Dec 2009
    Location
    Dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happened to my 06 vvti when I reversed, steering went heavy and light came on. Turned it off and on again, light disappeared and everything okay, and has been now for the last 2 years

  4. #4
    Regular Member GoldenWonder's Avatar
    Join Date
    Dec 2007
    Location
    Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'll check the level tomorrow just in case.

    I only had it on full lock briefly - I don't hold it against the 'stop' for anything longer than a second or two!

    I'm just paranoid that the exhaust fitter has done something - the steering rack is tucked away from the exhaust though?

    I'm hoping it was just a one off - a few people on here seem to have problems but I did lose all power steering until I restarted the car - its been many years since I felt steering as heavy as that!

  5. #5
    Regular Member cossiejay's Avatar
    Join Date
    Mar 2011
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri 150

    Engine : 1.9 cdti

    Year : 2007

    Default

    my steering light has been on for 2 years been through 2 mots checked everything still will not go off says low voltage and open circuit on fault code reader cant even take the bulb out

  6. #6
    Regular Member GoldenWonder's Avatar
    Join Date
    Dec 2007
    Location
    Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine went off completely though - reading around it could even be the alternator on the way out so I've obviously got a few things to check:-
    1) Fluid level
    2) Check connectors on steering rack? Just seems a coincidence that this has happened the same day the exhaust was changed - maybe all the banging and clanging has dislodged something!
    3) Check alternator is providing a good voltage

    I've also read somewhere you can reset the CIM by pulling some fuses which might be worth a try, but I've not managed to find which fuses they are?

  7. #7
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    If the light comes on once and doesn't come on again it can be ignored. I had the same thing on my first Vectra 'C' a 1.8 and it was the power-steering pump, which was replaced under warranty.

  8. #8
    Regular Member GoldenWonder's Avatar
    Join Date
    Dec 2007
    Location
    Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've checked the level this morning and it was midway between the min and max marks so I guess thats ok.

    I suppose time will tell if it does it again!

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by cossiejay View Post
    my steering light has been on for 2 years been through 2 mots checked everything still will not go off says low voltage and open circuit on fault code reader cant even take the bulb out
    You'll need to get if fixed because from 1 Jan 2012 illuminated fault lights in relation to power steering (and most others) are a failure from this date.

    http://www.dft.gov.uk/vosa/repositor...May%202011.pdf
    Last edited by dae36; 31st August 2011 at 13:55.

  10. #10
    New Member melvyn8181's Avatar
    Join Date
    Jul 2011
    Location
    north lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine did exactly the same but a coupe of weeks later me steering motor/pump went , got new motor/pump and still trying to get car to accept it without bringing a fault code up.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2012, 08:58
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. PLEEEEASE HELP - traction control light/power steering light on!!!
    By holdenvectra in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 28th June 2010, 23:39

Visitors found this page by searching for:

vectra c 2006 steerong wouldnt turn lights went off ans now cant start up

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •