User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Dti 2.0 (02) very noisy loss of power

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Dti 2.0 (02) very noisy loss of power

    Hello,
    I have recently had the spanner light come on if I put the over any high pressure this sends the car into limp mode. I have taken the egr off and given it a good clean and checked (as well as I can) for any cracks/holes in any of the hoses.
    This did not work for me and I still get the same problem, the car now over the past month has got noisier and nosier (tractor sounding) and even has even more loss of power. As if it is constantly in (limp mode) without the light being on.
    Any suggestions as what I might have done or what the problem may be?
    regards
    rich

  2. #2
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate,

    It could be a number of things. The best thing to do is get the codes read and then we can start narrowing it down and point you in the right direction.

    There might be a member in your area who will dor it for free. Try a thread title CODE READING IN YORK AREA? Then report bck your findings.

    Good luck

  3. #3
    Regular Member cossiejay's Avatar
    Join Date
    Mar 2011
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri 150

    Engine : 1.9 cdti

    Year : 2007

    Default

    i had a similer problem a couple of years ago on a vectra b it turned out to be oil starvation to the cam ended up replacing the engine ,not saying this is the problem you have

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power Steering noisy? What do you think
    By Envy in forum Vectra C / Signum Troubleshooting
    Replies: 13
    Last Post: 3rd October 2011, 19:06
  3. Power loss!
    By IceGlaysher in forum Engine & Drivetrain
    Replies: 7
    Last Post: 10th January 2010, 19:28
  4. Still loss of power!!
    By jonnynufc in forum Engine & Drivetrain
    Replies: 14
    Last Post: 5th July 2009, 00:07
  5. 2.0 dti power loss
    By maniac8569 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 8th August 2007, 23:47

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •