User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Lambda sensor

  1. #1
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Lambda sensor

    Hi all I'm a new addition to the forums and a new vectra owner, I'm after some advice on how to change the lambda sensor, I can't currently afford the £220 my local garage quoted so I'm left with no other option but to buy from a scrap yard and fit myself all help appreciated. 2004 1.9 cdti sxi
    Last edited by danno91; 25th August 2011 at 02:03. Reason: May help if I put my car on

  2. #2
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hmmm have i posted this in the wrong section or does no1 want to help

  3. #3
    Regular Member 6009tristanb's Avatar
    Join Date
    May 2011
    Location
    bispham, blackpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    why pay so much was the easy job to do mine and i also bought a universal one from ebay just had to cut the orginal plug off the old sensor and rejoin it the place i got it from was ebay at 17.99 the link is the one i bought odds on wont be for your car as its for a 3.2 but if you contact the seller he will help
    http://www.ebay.co.uk/itm/330510699795
    all you do when you change it make sure you have the right size spanner and get the engine hot as its easy to get off when its hot
    i checked mine once fitted and no fault codes after and its been on for nearly 2mth now no problems and only cost me £17.99

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Easy enough mate just disconnect an undo an swap over.

    Makes job easier of you run engine first to heat exhaust up.

    If you've got fault light disconnect batt for half hour afterwards that should clear it.

  5. #5
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks i got the part on the way hopefully be here in time for the weekend. i havnt had a fault light since its been tested, but my car is gudering alot while driving at 30-40 i hope this is the problem and not one of the many other faults i have seen while looking though past threads

  6. #6
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Have you had codes read recently??
    Maybe worth having a live data check

  7. #7
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    think it was 3 days ago i took it in as i was hoping it would be a warranty fault don,t think they done a live data check, but there was 3 codes which he explained to me as 1 was o2/lambda sensor one was where id hit break peddle while accelerating other was max turbo pressure exceeded, he told me the only one to worry about was lambda sensor so thats what im gunna sort first

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Did he tell you which one it was?

    Because you could swap them over to see if fault moves with it. That would prove if it's a faulty sensor or not

  9. #9
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No all he said was o2/lambda sensor is there more than one lambda sensor?

  10. #10
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    I could be wrong but I'm sure there's 2 a pre an post cat.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where to buy Lambda Sensor
    By signum04 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th May 2012, 08:56
  2. Lambda sensor
    By dan1983 in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 19th February 2010, 13:08
  3. lambda sensor again!
    By deg in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 5th November 2009, 23:49
  4. lambda sensor
    By deg in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 2nd November 2009, 18:35
  5. Lambda sensor - Z32SE - where is bank 1, sensor 1?
    By Kev_A in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 23rd February 2008, 14:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •