User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: help with fault codes

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default help with fault codes

    Hi all,

    i have been having the yellow spanner /car light now since i got the car (150 sri 2005 cdti) initialy i thought it may be the glow plugs as i was getting a glowplug fault, i have today cleared the codes after fitting the glow plugs and the following are the codes i am getting,

    does anyone know which one would light the car/spanner light?? as i cant afford to throw money at the car.


    P0650 - Malfunction Indicator (MI) Control Circuit Open
    (04) - Present

    B0970 - Hazard Warning Switch Telltale Malfunction
    (0F) - Present

    B2966 - Driver Doorknob Circuit Open or High Voltage
    (05) - Present

    any help appreciated

    thanks

    simon

  2. #2
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default hazard warning

    re above i checked the hazard warning switch and the hazard warning lights do not work so i may have found one of them, any idea if the hazard warning has a repaly or fuse?

    thanks

    simon

  3. #3
    Regular Member
    Join Date
    Jun 2011
    Location
    Elland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bobsimes View Post
    Hi all,

    i have been having the yellow spanner /car light now since i got the car (150 sri 2005 cdti) initialy i thought it may be the glow plugs as i was getting a glowplug fault, i have today cleared the codes after fitting the glow plugs and the following are the codes i am getting,

    does anyone know which one would light the car/spanner light?? as i cant afford to throw money at the car.


    P0650 - Malfunction Indicator (MI) Control Circuit Open
    (04) - Present

    B0970 - Hazard Warning Switch Telltale Malfunction
    (0F) - Present

    B2966 - Driver Doorknob Circuit Open or High Voltage
    (05) - Present

    any help appreciated

    thanks

    simon
    None would light the spanner light, as the first code is telling you that the spanner light is not working

    They are only electrical gremlins and nothing you *need* to spend money on. Only thing is, with the spanner light not working, you may be unaware if anything more serious occurrs.

  4. #4
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by hebblemarine View Post
    None would light the spanner light, as the first code is telling you that the spanner light is not working

    They are only electrical gremlins and nothing you *need* to spend money on. Only thing is, with the spanner light not working, you may be unaware if anything more serious occurrs.
    The car spanner light is intermitent, it comes on for a whole journey or just for seconds then goes of and comes back on ect, i still get other warnings eg door left open low fuel ect.

    glow plugs have been changed so i know its not that, i am thinking cim module as i also get random opcom faults from -cruise control/steering module however both of these work flawlesly, i may try cleaning the cim connector under the steering cowling.

    other than that i may open up the rev/speedo assembly and blank of the spanner light with some black plastic as it does my head in, if i did do this can anyone tell me if i would still get any serious warnings on the indicator that shows the radio station/fuel consumption ect???

    Simon

  5. #5
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile fixed

    1)

    P0650 - Malfunction Indicator (MI) Control Circuit Open
    (04) - Present

    this turned out to be the instrument cluster, remove both trim strips one above the radio and one above the headlight switch, lower the steering wheel and unclip the instrument cluster surround, there are then two torx screws holding the instrument cluster in, i removed the connector at the back of the cluster before cleaning both male and female connectors with wd40/cloth, re-assembled and the light has not come on since.

    2)

    B0970 - Hazard Warning Switch Telltale Malfunction
    (0F) - Present

    this was the connector at the back of the hazard warning switch in the dash next to the radio had falen out, re-connected and now working fine

    3)

    B2966 - Driver Doorknob Circuit Open or High Voltage
    (05) - Present

    apparently this is a common vectra electrical gremlin and dosn't seem to affect the operation in any way so i will be leaving it.


    hope the above helps someone.

    Simon.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fault codes?
    By farley2708 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 5th February 2012, 00:18
  2. fault codes
    By ADAM123 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 31st January 2012, 19:02
  3. Fault Codes
    By tony100la in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 10th November 2010, 09:49
  4. Fault Codes
    By cdms811 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 15th November 2007, 14:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •