User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Copper Grease on Engine Components?

  1. #1
    Regular Member john506's Avatar
    Join Date
    Mar 2011
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Copper Grease on Engine Components?

    I have a constant squeak noise coming from the alternator belt on cold starts, it seems to be coming from one of the cogs on the left side of the engine, when I spray WD40 into the [bearing ???] part, it stops for a short while but then just evaporates.

    I have a spray can of copper grease, if I spray this in the same spot will it do anything bad to the cogs, after all it is for high temperature situations, but I've read about not spraying it on certain alloys?

    The noise is really annoying me sounds like I have a banger when my engine is started. If copper grease is no good can someone recommend something else?

    Thanks!

  2. #2
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    change the belt only a few quid
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  3. #3
    Regular Member john506's Avatar
    Join Date
    Mar 2011
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    But then how much for someone to do it, as a quick fix?

  4. #4
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    get the belt and tensioner replaced, its all good to prove the fault with the likes of wd40 / copper grease but when you think thats going to be spinning at x000 rpms if your lucky its snaps and does no more damage, if your unlucky it snaps and wipes out some expensive components.

  5. #5
    Regular Member eaglepva's Avatar
    Join Date
    Jul 2007
    Location
    Up North
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same noise on start up to mate, going to try and spray some wd40 where you have said then seen if it stops.

  6. #6
    Regular Member john506's Avatar
    Join Date
    Mar 2011
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah I suppose you are right I'm just masking the problem, gonna get my cambelt changed soon so will get it done with that!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. copper pipe
    By fattony in forum Engine & Drivetrain
    Replies: 8
    Last Post: 12th October 2012, 22:25
  2. copper grease on wheel nuts
    By J P S in forum Suspension, Wheels & Brakes
    Replies: 24
    Last Post: 6th October 2011, 01:17
  3. just reported a copper for doing well over 40 in a 30
    By monty2000 in forum General Chat
    Replies: 63
    Last Post: 3rd July 2010, 10:04
  4. Helpful copper!
    By the_wave_rider in forum General Chat
    Replies: 7
    Last Post: 2nd July 2010, 20:44

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •