User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: 2.2 K&N question

  1. #1
    Regular Member Digital_kid's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 K&N question

    Hi,

    Fitted a Cone type filter to my SRi 2.2 and boy does it sound sweet so loud. Only thing is if im in 2nd gear between 1 and 2000 RPM when you accelerate slowly you get a slight pinking type noise. If you floor it you dont get this, I think there may be more air than juice going in is there a way to increase fuel or would I have to remap etc.

    Anyone else had this?

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what you need to do is to get the Airflow meter to re-calculate it's values..

    So, Disconnect the battery for 10 minutes.. then re-connect.. now take the car for a drive.. nothing thrashy, just a drive of about 5 - 10 miles.. this will then make the AFM adjust the fuelling values for the different air filter. It should drive without pinking after that, but remember pinking can also be caused by an early spark as well as too lean a mixture.

  3. #3
    Regular Member Digital_kid's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ace thanks mate will try this. Normal filter is ok which leads me to the filter.

  4. #4
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    AFM usually needs a 'help' when they filters are changed over..

  5. #5
    Regular Member Digital_kid's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cool thanks mate. Hey dont know if youve seen this before but mine is also saying "Check Safeguard" any ideas what this means on the computer?

  6. #6
    Regular Member Digital_kid's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks lads, took the battery off for 10mins connected back on.

    Put the radio code back in and went for a spin. No pinking! Nothing just a sweet note tell you sounds amazing.

    Oh and the "Check Safeguard" computer message has gone as well!

    Brilliant made up thanks again.

  7. #7
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No probs...

    one nice side effect of removing the battery lead for that long is it clears any present fault codes.. hence why you 'check safeguard' has gone..


    enjoy the car mate..

  8. #8
    Regular Member Digital_kid's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So the fault may still be there but not showing any more?

  9. #9
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    no, if the fault was present now, it would be showing again.

    The fault had been logged in the memory and it is the type of fault that, even if it's no longer a threat, will still be displayed until you've taken the car for a trip to the dealer.. so basically, you've cleared the code just like the dealer would have done, seen it's not a curent fault... and the best bit.... saved yourself £40..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GSI Inner tie rod question.
    By Lee_gsi in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 9th August 2011, 19:46
  2. question about hid
    By marc vectra sri in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 22nd July 2011, 23:15
  3. Vaux-Com / Op-Com question - Screen change question
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 16th May 2010, 23:54
  4. Just a question...!
    By Maxim007 in forum Styling
    Replies: 7
    Last Post: 26th January 2010, 20:12
  5. BSR question
    By soulman in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 6th October 2007, 22:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •