User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: 2.2 Direct problems

  1. #1
    Regular Member Paul_NI's Avatar
    Join Date
    Mar 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 Direct problems

    Ok I am sure you guys are all getting a little fed up with me cluttering the forum with my misfire problems

    However, I have been toying with the car and have discovered something new.

    I was all set to buy a new fuel pump as everyone here seems to think that is the problem and I an still not convinced it isnt, but....


    This all started after the FPR was replaced under recall by the dealer i bought the car of. after a few days the misfire appeared, I replaced the plugs which were in bad shape and all was good for a few days, then back to misfiring when pushing car over 2500-3000 rpm. Eventually I bought a code reader but no codes were recorded then the emissions light appeared and code P0303 appeared, reset and all was ok then the next day light appeared again and codes P0310 and P0303, again reset and all was ok. I could reproduce the fault by pushing over the 3000rmp limit.

    So last night i was driving home from work and the A road i usually used was closed for read works so I ended up on a B- road behind alot of cars so i decided to back off and play with the rpm limits and see if I could through the code... I took the car to 5000rpm in 2nd gear and all was good, but when I changed gear and backed off in 3rd, the emissions light reappeared and I read fault code P0303 misfire on cylinder 3 and she was definitely of a cylinder!! I couldnt stop so just erased the code as i drove and as soon as the code was reset the car cam back unto 4 cylinders and pulled away smoothly.

    So a few questions lol

    If this was the pump, surely the pump is mechanical and reset the code would have no influence?

    so code it be the coil pack or maybe a sensor, but what sensor?

    All theories are welcome

    Thanks
    Paul

    P.S. I also think i broke a spring on the same road as I now have a load popping noise from the front left
    Last edited by Paul_NI; 10th August 2011 at 09:54. Reason: more info

  2. #2
    Regular Member Paul_NI's Avatar
    Join Date
    Mar 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    anyone?

  3. #3
    Regular Member skidmark1's Avatar
    Join Date
    Sep 2010
    Location
    cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.2 Direct

    Trim : SRI

    Engine : YH 2.2 petrol

    Year : 2006

    Mileage : 85000

    Default

    does the problem with third injector wireing fault apply to the 2.2 direct as I have heard alot of people mention but with the 1.9cdti

  4. #4
    Regular Member Paul_NI's Avatar
    Join Date
    Mar 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    bump

  5. #5
    Regular Member skidmark1's Avatar
    Join Date
    Sep 2010
    Location
    cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.2 Direct

    Trim : SRI

    Engine : YH 2.2 petrol

    Year : 2006

    Mileage : 85000

    Default

    free bump

  6. #6
    Regular Member lizard's Avatar
    Join Date
    Oct 2006
    Location
    southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by skidmark1 View Post
    does the problem with third injector wireing fault apply to the 2.2 direct as I have heard alot of people mention but with the 1.9cdti
    No it doesnt...

  7. #7
    Regular Member Paul_NI's Avatar
    Join Date
    Mar 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok car has almost died....

    had the usual cold start misfire this morning, but this time it did not seem to leave as the car warmed up... headed for the motorway and as soon as I tried to accelerate, the EML came on, but no loss of power, just the misfire... plugged the code reader in while still driving, no codes so reset the light got up to about 65 and the light came on again, again no codes so reset and all seemed well. then as I past a slow lorry, the light came on and no power!!! a quick dart across the front of the lorry and onto the hard shoulder not fun.

    still no codes, but car will not go over 40 mph, I am thinking high pressure fuel pump as gone as it is still driving, no codes, EML stays off, but just will not go fast

    or could it be the swirl flaps are stuck closed/open as I was going to take the inlet manifold of this weekend and clean it out?

    Thanks
    Paul

  8. #8
    Regular Member Paul_NI's Avatar
    Join Date
    Mar 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok new Continental pump arrived on Saturday along with a 200ml tin of Wynns Petrol EGR cleaner.

    Fitted pump in about 20 mins!! I was a bit cautious as I was expecting fuel to spray all over the engine when I used the de-pressurise value jobbie, but only a trickle came out, which I would suggest meant there was no pressure in the pump and hence it was faulty.

    so pump changed started her up and all seemed well Now for the EGR cleaner... took the air feed off after the MAF and the car would not stay going long enough to spray the cleaner in, so I tentatively put the MAF back on and sprayed though it. I used the full tin, took about 5-10 to get it all in in short sprays. Tried to take the car for a short drive and It died as soon as it went back to idle emissions light came on and fault code P1112 and P0302

    Thought sod it! reset the codes started her up keep the revs up and give her a bit of a beating for about 2-3 miles, no more lights or fault codes and all seems good

    However, I am still no convince that the Swirl Flaps are ok... idle is still a little rough, (me being fussy probably) and I think I can feel a little hesitation when accelerating.

    Next is to block of the EGR

    Paul.

  9. #9
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Pleased you are making some progress ....................

  10. #10
    Regular Member lizard's Avatar
    Join Date
    Oct 2006
    Location
    southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Paul_NI View Post
    ok new Continental pump arrived on Saturday along with a 200ml tin of Wynns Petrol EGR cleaner.

    Fitted pump in about 20 mins!! I was a bit cautious as I was expecting fuel to spray all over the engine when I used the de-pressurise value jobbie, but only a trickle came out, which I would suggest meant there was no pressure in the pump and hence it was faulty.

    so pump changed started her up and all seemed well Now for the EGR cleaner... took the air feed off after the MAF and the car would not stay going long enough to spray the cleaner in, so I tentatively put the MAF back on and sprayed though it. I used the full tin, took about 5-10 to get it all in in short sprays. Tried to take the car for a short drive and It died as soon as it went back to idle emissions light came on and fault code P1112 and P0302

    Thought sod it! reset the codes started her up keep the revs up and give her a bit of a beating for about 2-3 miles, no more lights or fault codes and all seems good

    However, I am still no convince that the Swirl Flaps are ok... idle is still a little rough, (me being fussy probably) and I think I can feel a little hesitation when accelerating.

    Next is to block of the EGR

    Paul.
    Common problem is the swirl flaps matey, good few hours to strip them down and clean them, blank the EGR and fit a catch tank and the problem will never return...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 Direct Misfire Problems :(
    By jonny180 in forum Engine & Drivetrain
    Replies: 31
    Last Post: 14th April 2012, 20:00
  2. 2.2 Direct SRi - Fuel Problems.
    By tomtaylor15 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 24th September 2011, 05:52
  3. Vectra 2.2 direct SRI pump problems
    By gweston in forum Engine & Drivetrain
    Replies: 3
    Last Post: 12th September 2011, 07:24
  4. 2.2 Direct SRi fuel problems...
    By craig123 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 3rd November 2010, 15:36
  5. 2.2 direct sri problems
    By 22sri in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 11th July 2007, 14:37

Visitors found this page by searching for:

vectra z22h swirl valve

vectra c 2.2 direct P0303

vectra c 2.2 direct no more than 3000rpm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •