User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Couple of irritations......

  1. #1
    Regular Member JB007's Avatar
    Join Date
    Jul 2011
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Couple of irritations......

    She can't cook and never goes down...

    Seriously though...

    After a week of minor problems, my Vectra has developed a couple of irritations:

    1) Power steering light comes on for a few seconds when SOMETIMES turning right and/or accelerating - low fluid/leak?

    2) When coming to a stop, the revs go up and down, engine about to stall, then kicks back and settles. Usually after a long run on the motorway - sticking/dirty idle valve?

  2. #2
    Regular Member DAVIDD88's Avatar
    Join Date
    Jan 2011
    Location
    scottish region
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You answered your own questions lol

  3. #3
    Regular Member JB007's Avatar
    Join Date
    Jul 2011
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I was just asking, needed assurance. I'm very insecure

  4. #4
    Regular Member DAVIDD88's Avatar
    Join Date
    Jan 2011
    Location
    scottish region
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cool hth

  5. #5
    Regular Member JB007's Avatar
    Join Date
    Jul 2011
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    so car went back to the garage today.

    They checked the power steering level and all was fine. Found a problem when connected to the PC, but couldn't find anything so cleared the fault.

    Same with the revs, again no fault so didn't do anything.

    I collected the car, drove it 5 metres and the power steering light came back on, for a few seconds. It appears that it come on when accelerating from a stop, comes on for a few seconds then goes off. Stop at a junction, move off, come on then goes off. Faulty sensor? Which sensor?

    Revs still going up and down after a drive on the M1. I did tell them to clean out the idle valve, but didn't as they couldn't find a fault.

    So it will be going back tomorrow.

  6. #6
    Regular Member JB007's Avatar
    Join Date
    Jul 2011
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just picked car up from my friendly local garage.

    The revs is the air flow meter. They have quoted me £120 just for the part. The power steering light they think is the steering column and/or rack (as the rack is leaking). The power steering fluid is fine though. They have said it could be a sensor on the steering column, if so the steering column would need to be replaced "at a cost of a few hundred pounds."

    As I have already spent shed loads on it, they have advised me not to bother with these two problems and spend the money on all the shocks that need replacing also.

    I think they may have a point. :-(

    As the steering light comes on only when going up a hill and/or accelerating is it because perhaps the engine mounts are f*cked and moving? Just a thought.

    Anybody want to buy this f*cking **** heap?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. just a couple
    By Pwthebaldeagle in forum Quick Photo Album
    Replies: 12
    Last Post: 8th January 2013, 19:10
  2. a couple of my new car
    By gti72 in forum Quick Photo Album
    Replies: 1
    Last Post: 7th May 2012, 13:22
  3. Spotted a couple in Dundee the past couple of days
    By John LE in forum Spotted or put a flyer on a Vectra C/Signum or Insignia?
    Replies: 0
    Last Post: 2nd March 2010, 23:49
  4. Couple of small mods (Pics) and a couple of questions
    By bigdan in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 30th January 2009, 18:18
  5. a couple of old pics and a couple of new
    By Braggy in forum Quick Photo Album
    Replies: 15
    Last Post: 10th September 2007, 22:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •