User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 2.0 DTI engine spanner light?

  1. #1
    Regular Member Thom's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 DTI engine spanner light?

    hi guys, ive got the dreaded engine electronics spanner light on my dash which pops up shortly after starting the car and goes away after a minute or so. there is no change in vehicle performance, mpg or anything else - but this light sucks!

    ive read elsewhere on the 1.9cdti engines this is down to a glow plug failure, could this be the same for my car?

    it happens whenever i start my car from cold but not necceserily after being turned off for a short time and restarted.

    If so, any idea why this has come up, as i only replaced my glow plugs in jan - although they were ebay cheapies!

  2. #2
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Thom View Post
    hi guys, ive got the dreaded engine electronics spanner light on my dash which pops up shortly after starting the car and goes away after a minute or so. there is no change in vehicle performance, mpg or anything else - but this light sucks!

    ive read elsewhere on the 1.9cdti engines this is down to a glow plug failure, could this be the same for my car?

    it happens whenever i start my car from cold but not necceserily after being turned off for a short time and restarted.

    If so, any idea why this has come up, as i only replaced my glow plugs in jan - although they were ebay cheapies!
    You may have answered your own question with "ebay cheapies"
    Certainly the light coming on for that short time indicates glow plugs.
    You'll need to test them. I bought a set of NGK glow plugs from ebay, £35 delivered, I resisted the ones that cost £20.

  3. #3
    Regular Member Thom's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i actually didnt think something that simply has to get hot could deteriorate so quickly but it may seem they have - the cars getting a service in a couple of weeks when i have the time/money so i'll have a look at them then and stick some decent ones in this time!

    Thom

  4. #4
    Regular Member si_hoss's Avatar
    Join Date
    Apr 2009
    Location
    Stevenage, Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I believe on the DTI the glowplugs are only used when the outside temp is 5deg or below, so in winter you'll see the glowplug light come on then off when first switching the ignition on. So in this weather they won't even be used so unlikely it's making the EML come on.

    It could be a hundred reasons it's coming on, only way to pinpoint it is to have the codes read. Could be a vacuum thing on start up?

  5. #5
    Regular Member Jonsey's Avatar
    Join Date
    Oct 2010
    Location
    Walkden, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If someone near you has tech2 you will be able to get the codes read and try to pin point the problem.

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Where are you located Thom?

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by si_hoss View Post
    I believe on the DTI the glowplugs are only used when the outside temp is 5deg or below, so in winter you'll see the glowplug light come on then off when first switching the ignition on. So in this weather they won't even be used so unlikely it's making the EML come on.

    It could be a hundred reasons it's coming on, only way to pinpoint it is to have the codes read. Could be a vacuum thing on start up?
    Even when it's 18 degrees in the morning my glow plug light comes on for a second. I only changed them last month and since replacing them the EML light stays off, prior to that it would always stay on for a few seconds.

  8. #8
    Regular Member Thom's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi guys, im located in Durham in the North east - but as a student im concerned about the cost of tech2'ing my car - would it be pricey to have a list printed off - i assume only vaux can do it properly?

    I'm going to try the glow plugs as the car drives fine but does only run on 3cylinders for a second or two on startup (thought it was normalish!) if tech 2 is cheap enough ill do that too as a list would be nice however needing 4 new tyres i dont have much money!

  9. #9
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    THom, start a new thread on here called. Can anyone read my codes in Durham area? Alot of members have code readers and are happy to read the codes for you if you drive to them and most of the time it wont cost you a thing apart from maybe a 4 pack of beer and as a student I bet you've some lying around somewhere!

  10. #10
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When you say durham do you mean the actual ciry or surrounding villages ?

    if your willing to travel I have a Ms509 id happily hook up but i cant guarentee it will read the DTI as they are pedantic at best.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  3. Spanner Light and Engine Management Light
    By Paul_NI in forum Engine & Drivetrain
    Replies: 5
    Last Post: 8th August 2011, 13:42
  4. Engine and Spanner Light Before I Start The Engine
    By corderz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 24th March 2011, 18:48
  5. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •