User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Signum Turbo

  1. #1
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Signum Turbo

    how can you tell if the turbo does not work ?

    apart from the fact that the car is fast being a 2.8

    i cant hear the turbo whotsoever ....


    is there anything i can check to confirm if it is working

  2. #2
    Regular Member PORKBALLS29's Avatar
    Join Date
    Dec 2008
    Location
    Epping
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate. You cannot hear the turbo on the 2.8 infact the engine its self is pretty much silent. If the turbo wasn't working you'd know about it as you'd have no power over 2000 rpm.

  3. #3
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes i was amazed how silent it was ,even with starting up .
    just thought i might hear the turbo whistling a bit ...

  4. #4
    spoons
    Guest

    Default

    I fitted a boost gauge on mine, its really handy to see whats going on with the turbo,

    I had a split hose and it showed straight away on my boost readout.

  5. #5
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah i brought a boost guage yesterday
    just got to fit it spoons

  6. #6
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what boost should the signum be running ?

  7. #7
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    anyone

  8. #8
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    No idea a eml light would tell you of a fault

  9. #9
    Regular Member triple595's Avatar
    Join Date
    Mar 2011
    Location
    llandrindod wells
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    boost would be between 10 - 15 psi i would have thought

  10. #10
    Regular Member pipamish's Avatar
    Join Date
    Mar 2006
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2005

    Default

    So would it be fair to say on a 2.0 turbo you can hear it whistling and even the wastegate when releasing the accelerator

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SIGNUM 2.8 Turbo
    By millard2004 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd March 2011, 13:41
  2. signum 2.8 Turbo
    By afcbadam in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 23rd September 2010, 22:41
  3. Signum 2.0 Turbo
    By GrahameM in forum Engine & Drivetrain
    Replies: 11
    Last Post: 29th October 2009, 22:06
  4. My new Turbo Signum
    By V6 JDT in forum Quick Photo Album
    Replies: 11
    Last Post: 6th October 2008, 15:29
  5. Signum Turbo S
    By Meriva OPC in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 25th March 2006, 11:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •