User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Cruise control issue

  1. #1
    Regular Member
    Join Date
    Jul 2011
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Cruise control issue

    Hi,

    My 04 vectra has a strange problem with the cc, it will engage and work for anywhere between a few seconds and a few minutes and will then disengage randomly. it takes a few attempts to switch it back on again, but once on it will work for a bit then switch off again.

    Ive tried holding the clutch and brake pedal up with my feet while it was on, didnt seem to make any difference.

    Anyone know a good place to start looking into this?

    thanks

  2. #2
    Regular Member
    Join Date
    Jun 2011
    Location
    Elland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Chances are the contacts between the stalk and the CIM are dirty or knackered.

    Mine does the same - it's a common fault!

    The stalk can be removed by unseating the rubber gaitor and pulling the stalk out. You will have to pull quite hard! The contacts can then be cleaned and inspected. Sometimes a clean will do. Sometimes the contacts inside the CIM have become flattened down. One member managed to lift the contacts up a little inside the CIM and that worked. Looks fiddly and my fingers don't do fiddly very well! I put a little dab of solder on the stalk contacts and this worked for a while. I haven't yet been bothered to find out why the mod has failed - perhaps the soft solder has worn down.

    To see whether it's likely the CIM contacts, drive the car and apply a gentle pressure on the stalk away from you. If the CC engages normally (with pressure maintained), try applying pressure on the stalk towards you. If the CC then disengages, it's the CIM contacts.

    Try using the forum search, as there are probably other tips on this

  3. #3
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    67 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Moved

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  4. #4
    Regular Member
    Join Date
    Jul 2011
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your reply!

    Glad to hear its a common fault and possibly a simple fix, ill try cleaning the stalk contacts as you've mentioned. thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cruise control issue
    By Marky in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 6th August 2012, 12:29
  2. cruise control issue help
    By chris1984 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 12th June 2012, 19:25
  3. cim no way (cruise control issue)
    By unreal_event_horizon in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 22nd August 2011, 14:21
  4. Cruise control Issue
    By hopkinson06 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 18th February 2009, 02:49
  5. Cruise Control Issue
    By TheWildHaggis in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 11th December 2008, 14:59

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •