User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: hesitation between 1500-2000 rpm

  1. #1
    Regular Member
    Join Date
    Jun 2008
    Location
    Wrexham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default hesitation between 1500-2000 rpm

    Hi,
    I am starting to get a bit worried about my vectra. It's a 1.9cdti 150. 65000 miles and 4 weeks ago had a lot of work done on it: service, changed inlet manifold, changed egr, changed cambelt.
    When I got it back, I noticed there was a hesitation/judder between 1700-1900 rpm. Brought it back and they updated the ecu software and changed the fuel filter. Still the same problem now. It's going back to the dealer next week, but I am starting to loose faith. I will be checking/changing the vacuum hoses this weekend. I will also check the throttle body and the boost sensor.

    Does anyone have any idea what else it could be. To me it looks like the new egr valve has messed up my car, as it runs fine when I unplug the egr valve.

  2. #2
    Full Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Map it out and blank it off. Problem sorted...

  3. #3
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like the new EGR valve is not seating quick enough or maybe the EGR was jammed shut before, so hiding a different issue? Stick a stronger spring on the valve.

  4. #4
    Regular Member
    Join Date
    Jun 2008
    Location
    Wrexham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sorry, forgot to mention, I have never had any warning lights on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 5th August 2012, 11:02
  2. 3.0 V6 hesitation 1500 rpm (solved)
    By yoladeuche in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 4th November 2010, 10:59
  3. Cdti Hesitation At 2000 Rpm
    By CRAIG in forum Engine & Drivetrain
    Replies: 21
    Last Post: 9th October 2006, 13:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •