User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Towbar Trouble

  1. #1
    New Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Towbar Trouble

    Hi all, I've just bought a vectra after years of using Nissan Primeras (which turned out to be the must unreliable cars ever) and what can I say, Vectras are truely fantastic.
    This is the one I have just got http://www.autotrader.co.uk/classifi...72lb?logcode=p

    I am getting a towbar fitted and know absolutely nothing about Vectras but I was told I need some sort of relay for the electrics?
    I am getting the towbar fitted on Friday so if anybody could explain/help me with what this relay is I would appreciate it very much
    Thank you

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    You need more than a relay.

    You need a fitting kit and module.

  3. #3
    New Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by lee gsi View Post
    You need more than a relay.

    You need a fitting kit and module.
    Hi thanks for your reply!
    I'm not entirely sure what they are?

    On order I have the towbar and an electrics kit.

  4. #4
    Regular Member Al 22 dti's Avatar
    Join Date
    Mar 2011
    Location
    pontefract
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 57 zafira 1.9 cdti design

    Trim : design

    Engine : 1.9 cdti

    Year : 2008

    Default

    buy and fit this..

    its the same as mine and it woks perfectly...


    http://www.ebay.co.uk/itm/7-Way-Bypa...ht_1814wt_1141

  5. #5
    Regular Member
    Join Date
    Sep 2007
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I fitted my towbar , it came with a wire harness and a fuse , plug in the harness to the fuse box in lefthand side if boot and add the fuse ... n# 13 or 11 cant remember .
    then its all go , need to drill the boot floor to bolt on the towbar though , took me about an hour all in .
    HTH

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    this was mine , add 26 quid for the bypass wiring . http://www.towequipe.co.uk/products/...-02on-kit.html

  7. #7
    New Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Al 22 dti View Post
    buy and fit this..

    its the same as mine and it woks perfectly...


    http://www.ebay.co.uk/itm/7-Way-Bypa...ht_1814wt_1141
    Hi a garage is fitting mine and sadly it's on friday so i dont have time to order but if i buy a standard 7 way relay kit will this do the job?

  8. #8
    Regular Member boba's Avatar
    Join Date
    Aug 2008
    Location
    The Kingdom of Fife!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by WastingLight View Post
    Hi a garage is fitting mine and sadly it's on friday so i dont have time to order but if i buy a standard 7 way relay kit will this do the job?
    Yes it will do OK. All that you will lose out on is that the proper Vx kit and a Tech2 senses when there is a trailer attached and (IIRC) switches off the reversing light and rear fogs. No big deal but the Vx kit is a whole lot easier to fit.

  9. #9
    New Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by boba View Post
    Yes it will do OK. All that you will lose out on is that the proper Vx kit and a Tech2 senses when there is a trailer attached and (IIRC) switches off the reversing light and rear fogs. No big deal but the Vx kit is a whole lot easier to fit.
    Thank you!
    I am pushed for time as I travel on Friday night, is it imperative I have a relay? I've never had to have one on another car

  10. #10
    New Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My towbar was fitted today

    Just a quick question, when I unlock the car after pressing the button on the remote twice, the numberplate lights come on and dont go off until i lock the car again. Is this supposed to happen?
    I noticed the interior light in the boot doesn't come on at all and i was wondering if it was a wiring fault

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. more trouble
    By pud wayman in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 23rd March 2012, 07:49
  2. still trouble...
    By ADAM123 in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 19th February 2012, 15:32
  3. Fan trouble
    By xf8u39 in forum Bodywork & Interior
    Replies: 3
    Last Post: 18th March 2011, 19:06
  4. Anyone else having trouble
    By ianuk in forum Vectra C / Signum Car Chat
    Replies: 31
    Last Post: 8th January 2010, 19:57
  5. Oh No... I'm in trouble now....
    By spoons in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 24th September 2006, 10:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •