User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: resister for blowers

  1. #1
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default resister for blowers

    need a new resister for my blowers seen this in ebay but i messaged the boke to ask if its a GM one, got a message back saying its a copy anyody brought one? http://cgi.ebay.co.uk/ws/eBayISAPI.d...=STRK:MEWAX:IT

  2. #2
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    dont matter ordered one, ill soon find out if its any good

  3. #3
    Regular Member hagga's Avatar
    Join Date
    Sep 2006
    Location
    kingswinford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My guess is it'll be fine.. resistors are cheap to make so nowt special about an overpriced vx one.

  4. #4
    Full Member
    Join Date
    Oct 2008
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    you just need to replace the resistor from maplins! - £2.00 fix do a search dude!

  5. #5
    Regular Member rich r's Avatar
    Join Date
    Feb 2011
    Location
    Selby
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Generally it's not the resistors that fail in the pack, it's the thermal fuse on the end.

    Are your symptoms that it only works on fan speed 4 (ie full speed)? If so it's just the fuse. Do a search for how to replace that - it's a cheap part you can get from Maplin.

    Or does it work on some speeds but not others? If so, then it's a failed resistor. Unfortunately you can't replace the individual resistors in the pack as it's a sealed ceramic block. So you have to replace the whole pack.

  6. #6
    Regular Member
    Join Date
    Nov 2009
    Location
    Cheshire + East Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Nice find, might order one myself.

    Blower hasn't worked on setting 1 since i bought the car, 2,3,4 all working fine - time to fix

  7. #7
    Regular Member rich r's Avatar
    Join Date
    Feb 2011
    Location
    Selby
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    That's definitely not the cheap thermal fuse fix, sadly. New resistor pack time...

  8. #8
    Regular Member vectra2002's Avatar
    Join Date
    Nov 2008
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by steve533 View Post
    you just need to replace the resistor from maplins! - £2.00 fix do a search dude!
    ya right ere, i got 1 from ere, 5 mins later all done and workin

  9. #9
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I lost settings 1 and 2, so it was the resistor pack that had failed
    I don't use setting 1 so hadn't noticed until setting 2 failed
    I also decided to buy one from eBay UK, for £15
    Due to an error within PayPal my transaction did not process completely and I didn't notice which I corrected three days later
    The part arrived three days later

    Fitting was straight forward, although the resistor pack is awkard to access
    The trick was to work upside down in the foot well
    The old unit was rotten and showing signs of internal failure
    I also checked for water and corrosion, but could find none

    Before reassembly I tested and it worked on all settings

    I then went for a drive to run air through the system, and there was a acrid smell for the first 30 minutes, presumably the coating within the resistor pack
    After running on each fan setting the smell disappeared

  10. #10
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    my old resister worked on 2,3,4 i got the mplins fuse and fitted that and it still worked on 2,3,4 so it wasnt the fuse the past month its been dodgy and worked on 2 and 3 only some times ut always on 4 so its defo the resister be nice to have the aircon on 1 with out hearing the fan

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I cant get the link for fan resister
    By Mopar Man in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 3rd June 2012, 12:53
  2. Resister pack
    By sebadee in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 18th September 2011, 10:33
  3. help with blower resister
    By chris1804 in forum Electrical & ICE (including SatNav)
    Replies: 23
    Last Post: 11th August 2011, 21:08
  4. heater resister were from?
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 8th March 2011, 14:35
  5. resister
    By tditony in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 29th September 2009, 23:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •