User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: black smoke both at tick over and under power

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    machynlleth powys
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default black smoke both at tick over and under power

    hi all my car is really starting to annoy me its a 150 cdti 54 plate just had a new dmf, clutch, injector, inlet manifold gasket, intercooler. i have cleaned the boost sensor and egr valve.
    the car seems very underpowered also the smoke doesnt smell like diesel either more of a sooty smell
    hope someone can help.

  2. #2
    Regular Member
    Join Date
    Jun 2011
    Location
    Elland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Was going to suggest injectors, but you say it's had this done.

    Throttle body / valve inoperative / stuck mostly shut?

    MAF faulty / bad connection?

    Inlet air hose leak / fallen off?

    Has this problem started since you have had any of these jobs done??

    How about a code reader to make sure the bits that have been cleaned etc. are working properly?

    Just some thoughts!

  3. #3
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default

    Moved to correct section !

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  4. #4
    Regular Member
    Join Date
    Jun 2011
    Location
    machynlleth powys
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    just inspected my throttle body does the big black pipe that comes from it go to the intercooler? if so mine has oil deposits in the pipe its minging oil soot basicly dirty as hell should it be like that? inside the throttle body is sooty as hell too.

  5. #5
    Regular Member
    Join Date
    Jun 2011
    Location
    Elland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes it does.

    In the direction of airflow, it's air filter -> turbo -> intercooler -> throttle body (inlet manifold).

    Problem is that exhaust gases (from EGR) mix with oil vapour (from crank case vent) and make this horrible mess you're talking about. It happens all the time and the only way round it is to: clean regularly and / or do something preventative like blank / disable the EGR (which is also probably covered in black snot) and / or vent the crankcase fumes to atmosphere.

    Try to check the operation of the throttle body - I would think it should open with the ignition in position 2 and shut when off.

    The EGR may be giving you issues - many on here have identified a dodgy EGR by unplugging it and driving the car: THIS WILL THROW A CODE, but if the car drives normally, then it's likely the EGR is the culprit.

  6. #6
    Regular Member triple595's Avatar
    Join Date
    Mar 2011
    Location
    llandrindod wells
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    try blanking the egr first and see

  7. #7
    Regular Member
    Join Date
    Jun 2011
    Location
    machynlleth powys
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    throttle bodyis off was slightly sticking took off the black part at the bottom with all the mechanism in and circit board in that is full of oil should it be ?

  8. #8
    VIP-Member Damo77's Avatar
    Join Date
    May 2010
    Location
    Petersfield, Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No it shouldn't have oil in it

    Apparently the 150 suffers from this quite a lot

    Some interesting reading in this thread:- http://www.vectra-c.com/forum/showthread.php?t=87919

    HIH
    Damo
    Already replaced:-
    Alternator,
    Drilled/Grooved Discs & Pads, Eibach Springs, EGR Valve, 50W HID's 6000k, K&N Panel Filter, LED footwell & boot lights

  9. #9
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Arrow

    Quote Originally Posted by hebblemarine View Post
    Yes it does.

    In the direction of airflow, it's air filter -> turbo -> intercooler -> throttle body (inlet manifold).

    Problem is that exhaust gases (from EGR) mix with oil vapour (from crank case vent) and make this horrible mess you're talking about. It happens all the time and the only way round it is to: clean regularly and / or do something preventative like blank / disable the EGR (which is also probably covered in black snot) and / or vent the crankcase fumes to atmosphere.

    Try to check the operation of the throttle body - I would think it should open with the ignition in position 2 and shut when off.

    The EGR may be giving you issues - many on here have identified a dodgy EGR by unplugging it and driving the car: THIS WILL THROW A CODE, but if the car drives normally, then it's likely the EGR is the culprit.
    This is why a lot of members on here have blanked their EGR valves and done the CCV by pass which eliminated all these issues.It's simple and easy to do.FELIXX.

  10. #10
    Regular Member
    Join Date
    Jun 2011
    Location
    Elland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by felixx View Post
    This is why a lot of members on here have blanked their EGR valves and done the CCV by pass which eliminated all these issues.It's simple and easy to do.FELIXX.
    Mmmm, it's all covered quite comprehensively on here

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 150 cdti LOSS OF POWER AND BLACK SMOKE HELP
    By STRETCH2009. in forum Engine & Drivetrain
    Replies: 0
    Last Post: 4th September 2012, 14:19
  2. Black Smoke and loss of power
    By danny1992 in forum Detailing and Car Care Discussion
    Replies: 18
    Last Post: 2nd August 2010, 16:33
  3. Signum 120 CDTi black smoke and loss of power @ low revs!!!!
    By siw8158 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th July 2010, 17:08
  4. Lumpy tick over and no low end power - Help
    By markluk in forum Engine & Drivetrain
    Replies: 2
    Last Post: 8th June 2009, 07:58
  5. Tick over 2500 rpm and loss of power
    By Swanni in forum Engine & Drivetrain
    Replies: 1
    Last Post: 27th March 2009, 08:00

Visitors found this page by searching for:

Vectra c smoking under body

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •