User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: glow plug problem or relay??

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default glow plug problem or relay??

    Hi all,

    I am a new member and have an issue with the car and spanner light showing on the dash for the first mile of driving, it normally goes out, sometimes it can come on during a drive and tends to stay on longer after stopping and then starting again.

    after an opcom diagnosis check i get the following

    Fault codes
    P0380 - Glow Device General Error
    (08) - Not present

    P0650 - Malfunction Indicator (MI) Control Circuit Open
    (04) - Not present

    i have then gone on to do a couple of output tests, here are the results

    Glow time telltale test

    when running i get a Glow plug light showing on dash

    Glow time relay test

    Battery voltage 12.3
    Glow time relay inactive 12v
    Diagnosis glow time relay inactive

    i then pressed run test and got the following


    Battery voltage 13.4
    Glowtime relay active 0v
    Diagnosis glow time relay inactive

    any ideas anyone befor i go out and buy a relay and or glowplugs??? anyone prepared to run the two tests above and see what you get or can inerpret the results??

    Simon

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    do you drive an estate & or auto?

  3. #3
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra

    no mine is a 1.9 cdti sri hatch 150ps 2005

  4. #4
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Relays rarley go probably glow plug. I would change them all.

  5. #5
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Do a resistance test on the glow plugs.

    Take the plug off the top and put a meter between the tip and a good earth.

    Should be about or less than 3 Ohms (I think)

  6. #6
    Regular Member
    Join Date
    Jun 2011
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    read a similar post and it said around 30 ohms m8.

    measured 1 and 2 on mine the other day , one was 1460 ohms and no 2 didnt even register !! Having trouble getting them out though.

  7. #7
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Another good test is if they glow red at the tip they are ok if they glow red in the middle or do not go red all they destined for the bin. Nothing better than good old diagnostics.

  8. #8
    Regular Member
    Join Date
    Jun 2011
    Location
    manchester uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default fixed

    i replaced the glow plugs and the glow plug code went but the P0650 code persisted, i finally traced it to


    P0650 - Malfunction Indicator (MI) Control Circuit Open
    (04) - Present

    this turned out to be the instrument cluster, remove both trim strips one above the radio and one above the headlight switch, lower the steering wheel and unclip the instrument cluster surround, there are then two torx screws holding the instrument cluster in, i removed the connector at the back of the cluster before cleaning both male and female connectors with wd40/cloth, re-assembled and the light has not come on since.



    hope the above helps someone.

    Simon.

  9. #9
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Thanks for the update

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. glow plug relay
    By iwtand in forum Y & Z30DT Specific
    Replies: 13
    Last Post: 29th January 2012, 14:25
  2. For Sale: Switches,Glow plug relay
    By bigmac in forum Parts for sale
    Replies: 3
    Last Post: 14th June 2011, 20:00
  3. glow plug relay and glow plugs
    By bobk1 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 3rd September 2009, 17:02

Visitors found this page by searching for:

vectra 1.9 cdti p0650

diagnosis glow time relay

glow relay active 0v is this normal

vauxhall vectra glow plug relay

vauxhall vectra 1.9 diesel glowplug relay

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •