User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Holiday blues

  1. #1
    Regular Member
    Join Date
    Oct 2009
    Location
    Oxford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 2.2i

    Year : 2006

    Default Holiday blues

    I've just come back from a week in Yorkshire. Weather was lovely, but the Siggie's not happy. It started making clonking noises, which I put down to the exhaust - a faulty bracket, and something coming loose. The poor bumpy minor roads in the Dales din't help, obviously. When I looked underneath I could see something hanging down.

    About Tuesday the broken bracket (or whatever it was) dropped off and the clonking stopped. Everything seemed OK again, but it was obviously too good to last.

    On the way home on the M40 I was overtaking in the central lane, when the cruise control disengaged, the engine lost power and things became unhappy. The exhaust gases light came on and we limped home with virtually no acceleration (although it would get up to 60 or 70 mph - just not very quickly).

    So I assume it's time for a new exhaust? Given that Signum exhausts are not common, what's the best bet? I don't trust Kwikfit to give me an honest diagnosis, the stealers will charge a fortune and I'm not totally certain it is just a simple failed exhaust.

    BTW it's a '54 2.2i petrol model.

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    If the light is showing on the dash, get the fault codes read too

    As for the exhause bracket, I got a mate to weld a new one to mine. He shaped it around the pipe to give a better weld, and it's held solid for a few months now.

  3. #3
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Rusted exhausts don't usually cause the car to go into limp mode, so there's something else going on.

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    Oxford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 2.2i

    Year : 2006

    Default

    Jezzy, you were right - fuel pump has gone again. The left hand front spring had also snapped as well. (that's not to mention needing new front and rear disks, new exhaust and tyres).

    Apparently a dealer fitted exhaust will cost me £850 whereas MJI would charge me £375 for a stainless one - seems like a no-brainer.

  5. #5
    Regular Member
    Join Date
    Aug 2010
    Location
    Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by achapman View Post
    Jezzy, you were right - fuel pump has gone again. The left hand front spring had also snapped as well. (that's not to mention needing new front and rear disks, new exhaust and tyres).

    Apparently a dealer fitted exhaust will cost me £850 whereas MJI would charge me £375 for a stainless one - seems like a no-brainer.

    My front NS spring snapped on holiday too.
    Cost me a new tyre as it dug into the side wall. The said tyre was only two weeks old too, I had the front pair replaced before my hols.

    Get em replaced in pairs, extra cost I know but the other could be weakened.


    Mick

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bank holiday blues
    By oneil in forum General Chat
    Replies: 17
    Last Post: 27th August 2012, 17:22
  2. Thank you Blues n twos
    By Derek Mc in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 11th September 2010, 13:28
  3. I've got the remap blues...
    By nutron in forum Vectra C / Signum Car Chat
    Replies: 49
    Last Post: 1st September 2007, 19:28
  4. Travelling blues
    By robzc in forum General Chat
    Replies: 9
    Last Post: 12th April 2007, 15:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •