User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Wipers stupidly slow / struggling

  1. #1
    Regular Member Kev_G's Avatar
    Join Date
    Jul 2009
    Location
    C:\Uk\Chester_North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Wipers stupidly slow / struggling

    I got the vectra back today and the wipers hardly move at all would this be a linkage or motor?

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    I'd guess at the motor mate

  3. #3
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Sounds like the motor too, might be worth removing the wiper arms and scuttle panel and giving the knuckle joints a skoosh with WD40 or spray grease first.

  4. #4
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Sounds like the linkage is seizing

  5. #5
    Regular Member Kev_G's Avatar
    Join Date
    Jul 2009
    Location
    C:\Uk\Chester_North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ill have to try later shame its battered down with rain all weekend

    Thanks Guys

  6. #6
    Regular Member
    Join Date
    Mar 2010
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It will be the linkage siezing as said, new ones are about £80 IIRC

  7. #7
    Regular Member Kev_G's Avatar
    Join Date
    Jul 2009
    Location
    C:\Uk\Chester_North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  8. #8
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER



  9. #9
    Regular Member Kev_G's Avatar
    Join Date
    Jul 2009
    Location
    C:\Uk\Chester_North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by troutybrown View Post
    i could kiss you................ but i wont thank you

  10. #10
    Regular Member
    Join Date
    Mar 2010
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by troutybrown View Post
    It is not these that sieze, these just drop off, the spindles seize in the alloy housing. IMO secondhand one are false ecconomy if you are keeping the car.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. front wipers not working on slow or intermittent
    By aconway in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 6th August 2011, 14:13
  2. Really Slow Wipers
    By MHowVECSRI07 in forum Bodywork & Interior
    Replies: 10
    Last Post: 10th February 2009, 17:11
  3. 07 plate vectra wipers slow!!!!!!!!!!!!!!
    By mitch in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 15th August 2008, 17:44
  4. Slow front wipers
    By vectragsi3.2 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 12th March 2008, 10:12
  5. Wipers on a go slow
    By Neil in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 24th April 2007, 12:35

Visitors found this page by searching for:

vectra c wipers going slow

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •