User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Dti poor starting sorted

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Dti poor starting sorted

    After a year of poor starting...and getting worse, I changed the glow plugs today (NGK £35) and a new battery £68, starts instantly! Makes me wonder why I left it so long!!

  2. #2
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you'll know better next time then lol

  3. #3
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Didn't you have a spanner light at all?

  4. #4
    Regular Member
    Join Date
    Jul 2009
    Location
    Brighton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What battery did you go for?
    My 1.9 CDTi takes 4-5 turns to start, so plan on getting a decent battery soon.

  5. #5
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    Didn't you have a spanner light at all?
    I've had the spanner light on for a few seconds every time I start for 2 years, I didn't know glow plugs caused it to come on?

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DHobbs View Post
    What battery did you go for?
    My 1.9 CDTi takes 4-5 turns to start, so plan on getting a decent battery soon.
    To be honest I can't remember the make. I bought it from a tyre place in Littlehampton which is not far from you in Brighton. I just gave them the model etc and he pointed out that it needs to be heavy duty.

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Croxley View Post
    I've had the spanner light on for a few seconds every time I start for 2 years, I didn't know glow plugs caused it to come on?
    Just an update..the spanner light stays off now!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Poor starting 1.9cdti - sorted
    By alcutler in forum Engine & Drivetrain
    Replies: 0
    Last Post: 24th March 2012, 15:24
  2. poor starting
    By tomo610 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 15th January 2012, 19:21
  3. Poor starting
    By Croxley in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd March 2011, 20:25
  4. Poor Starting
    By st2malo in forum Engine & Drivetrain
    Replies: 10
    Last Post: 4th March 2010, 16:09
  5. poor starting
    By m1ke823146 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 2nd November 2009, 12:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •