User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Vectra 2.2 Direct Petrol - strange behavior

  1. #1
    Regular Member rodzynx's Avatar
    Join Date
    Jul 2011
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Vectra 2.2 Direct Petrol - strange behavior

    Hi,

    Recently I have noticed strange behavior of my Vectra engine. so this what is happening.

    The vectra 54 plate 2.2 42k miles.

    It was sunny hot day and I was on the M1 standing in the congestion. The car suddenly stopped with spanner light on. I couldn't start it but the starting motor sounded ok (like no petrol or spark).
    After pushing it on the hard shoulder and 5 min of rest the car started. I drove maybe 3 min and it stopped again. After another wait and stop I have called the AA. They came after 2 hours and they said that the problem was low level of oil
    True it was low but I didn't thought Vectra is so sophisticated car.
    The light went off so I drove home and I thought it is sorted.

    3 weeks later similar situation I was driving down M25, congestion, spanner light came up. Suspecting the situation I drove on the slow lane. After some time car stopped. This time I waited with an open bonnet for about 20 min, and car started without any problems and I manged to get to London where i had to repeat the action of cooling down the engine. When I was returning that night to Cov (no congestion and cool night) I had no problems even a hick up.

    Now Mechanic with his computer said that car has recorded a low level of fuel pressure and quoted 500 for fixing the pump, sensor, filter and labor.

    But is it definitely the pump? why it occurres only during high temperature?

    In the city car behaves quite ok with no problems.

    I will appreciate all comments.

  2. #2
    Full Member lizard's Avatar
    Join Date
    Oct 2006
    Location
    southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like the Fuel pressure regulator matey, common fault and also a recall from vauxhall, check with vauxhall uk to see if yours has been done, have you had it from new...

  3. #3
    Regular Member rodzynx's Avatar
    Join Date
    Jul 2011
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thank you for the reply. I have phoned Vaux dealer and they have replaced the sensor for free. We will see if it was it.

  4. #4
    Regular Member
    Join Date
    Feb 2010
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine had the same problem it will be the fuel pressure regulator. If its the fuel pressure pump the car wouldn't cut out. VX did the recall on my Vectra and everything is fine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 Direct Vectra Auto Gearbox - Strange Problem
    By Krusty3380 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 7th May 2012, 21:12
  2. oil leak from vectra c 2.2 direct petrol
    By bigf in forum Engine & Drivetrain
    Replies: 0
    Last Post: 30th March 2012, 16:05
  3. Vectra 2.2 direct petrol 2005 will not start
    By bakercbak in forum Engine & Drivetrain
    Replies: 0
    Last Post: 8th October 2011, 15:05
  4. 05 Vectra 2.2 direct petrol. Cutting out
    By mani2002uk in forum Engine & Drivetrain
    Replies: 8
    Last Post: 1st August 2011, 18:37
  5. P0141 on Vectra 2.2 direct petrol 2004
    By chips in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 20th September 2010, 18:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •