User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: Erratic Revs

  1. #1
    Regular Member
    Join Date
    Jul 2007
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Erratic Revs

    Hi all, your expert advice is needed!

    My cars problem has developed over time rather than overnight so here goes:

    The idle speed is erratic about 50% of the time to an extent that it stalls, this is not all the while, as I said 50% of the time there is no problem. Once it as held at about 600 then it stays there with no fluctuation. If I take the revs up high and release the pedal, the revs drop steadily, hold slightly at about 1200 and drop to 600 – sometimes as it drops it drops below 600 and then starts a to and fro until it eventually stalls. Unsure if this is part of it but the ‘engine emission light’ is on constant. Haynes recons that there could be a vacuum leak but I cannot find one, although there is a very soft repeating ‘t’ sound coming from that area. The chain was changed about 15000 miles ago and the car as now done about 69000, there is some rattle but only slight.

    Because I do low mileage and had not given it a blast for sometime I added some injector cleaner to the petrol, I got better fuel consumption but it didn’t cure the problem – I have also changed the plugs, air filter and oil – I have also checked to earth and there are no problems?

    Performance wise she still holds her own and pulls a 12000kg caravan with little effort

    Any suggestion

    1.8 club, 52 plate, saloon. (reprogrammed 2 years ago due to replacement of airbag ecu and electrical spikes/problems – it was reprogrammed to Si specs not club (not my doing))

  2. #2
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    you say your timing chain is rattleing, pretty sure there all belts mate.

    wonder what the rattle is

  3. #3
    Regular Member
    Join Date
    Jul 2007
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Too old to know the difference

    But read the thread containing the info about the cooling temp sensor so i'll start from there.

  4. #4
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    do the pedal test as well mate to get ya fault codes will be a good start

  5. #5
    Regular Member ChrisBilly's Avatar
    Join Date
    Jul 2009
    Location
    The Rift, Cardiff
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My 1.8 had the same problem, but would rarely stall. It turned out to be a leaking egr, it was sucking air from the engine bay and causing the car to run rich. I only discovered it was the cause after a member on here suggested spraying carb cleaner on/over/around the egr while the engine is running at idle. Sure enough the engine cut out, so i knew 100% the egr was the cause. I paid ~£20 for one from a vec b at the scrap yard.

  6. #6
    Regular Member
    Join Date
    Jul 2007
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thank you TimTay I did not know about the pedal test – so I did it:

    There is an error in the cruse control which I already knew about – it’s set up as a Si not a club!

    P0100 Mass or volume air flow malfunction

    P0134 02 sensor circuit, no activity (bank1, sensor 1)

    P0170 Fuel trim malfunction

    My guess is that these 3 are inter-related

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Lambda sensor mate

    P0134 02 sensor circuit, no activity (bank1, sensor 1)

  8. #8
    Regular Member
    Join Date
    Jul 2007
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok! what and were is the lambda sensor

  9. #9
    Regular Member
    Join Date
    Jul 2007
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    From my readings I assume the lambda sensor is the 02 sensor on the ex. manifold

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes mate, there is most likely 2, one before the cat and one after.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Erratic revs on start & EML on under load.
    By paz_badboy4life in forum Engine & Drivetrain
    Replies: 4
    Last Post: 26th August 2012, 16:55
  2. 3.2 erratic idle
    By Annalogg in forum Engine & Drivetrain
    Replies: 3
    Last Post: 25th June 2010, 13:26
  3. Erratic CANBUS
    By johnmac in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 28th May 2009, 22:30
  4. massivly erratic 3.0l
    By Adamdavi3s in forum Engine & Drivetrain
    Replies: 6
    Last Post: 7th August 2008, 16:09
  5. Trip Computer Erratic
    By nishaal in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 26th June 2008, 18:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •