User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Cat Or Lambda

  1. #1
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Cat Or Lambda

    I Already Got A Thread Up That I Failed My M.O.T Due To Emissions...

    Cheapest Cat I Can Find Is £220..Plus Lambdas..We Are Talking £330 All In...

    Whats The Chances Of It Just Being Lambda`s That Are ****** Rather Than The Cat ?

    Got Told That When Removing Lambda`s From The Cat They Usually Break

    If I Go Down The New Cat/Lambda`s Thats My Piggy Bank Well And Truly Burst

    Codes That Were Showing Up Were

    P0420
    P0170
    P0420 And Has A "P" After It

  2. #2
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if heated and removed correctly they dont break. just when folk go gung ho. 9 years of fitting exhausts and tyres never had 1 break.

  3. #3
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Think the issue with them is they can take the threaded insert, out of the cat, with them when they are removed Tam, but as Tim say heating them should prevent this. I would do the lambdas first then and only then think about the cat.

  4. #4
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    I think the issue you have is more related to the MAF, when this goes wrong the car over fuels resulting in the Lamba on the Cat being burnt out and emissions issues.
    Might be worth spraying the MAF with some carb cleaner to give it a clean.
    Have you got a way of swapping parts with another 1.8 owner?
    Also only buy geniune GM parts or OEM as there are some cheap parts out there which will cause you more issues
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  5. #5
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just In..******* ******* Down With Rain Oot There

    Been On My Wanders...Tried To Find Oot If It Was Cat/Lambda..But To No Avail...

    So Had Enough...Vec Could Very Well Be Going Once I Finally Get A Ticket On It...
    Ordered 2 Sensors And Cat...Pick Them Up Tomorrow...

    And Thats My Pocket £400 Lighter..Got A Guy Fitting It For Me Friday For £50...Would Give It A Go Myself But Well And Truly ****** Off

    Coz If I Got A Bolt That Snapped Or Refused To Budge Or Summit..Would Probably Launch Ratchet Through Windy

  6. #6
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    be a fool not to put the lambdas in first to see if that sorts it man. like said its throwing up the same faults as my inlaws and it was only 1 lambda.

  7. #7
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    my monies still on the MAF as I had the same issue, I really would try that first before anything else. Hopefully the sensors are just showing incorrect readings due to overfueling rather than being faulty. If you fit new sensors and the MAF is faulty they will just damage the sensors again or throw up the same fault code.
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  8. #8
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by TimTay View Post
    be a fool not to put the lambdas in first to see if that sorts it man. like said its throwing up the same faults as my inlaws and it was only 1 lambda.
    Think I Will Got Get Sensors 1st Then And Bang Them In...But Are They Gonna Cure My Emissions Problem ?

    Quote Originally Posted by merikiito View Post
    my monies still on the MAF as I had the same issue, I really would try that first before anything else. Hopefully the sensors are just showing incorrect readings due to overfueling rather than being faulty. If you fit new sensors and the MAF is faulty they will just damage the sensors again or throw up the same fault code.
    I Only Noticed The P0170 Code Yesterday...That Aint Been There Long...Other 2 Keep Coming Up..Will Try MAF With Carb Cleaner As Well

  9. #9
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thats the whole point of them! there not there for show lol

    0170 can be caused by several things 1 being faulty lambdas

    if i was a betting man the rear sensor is all you will need! lee gsi was saying the same so did someone else i think!

  10. #10
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by TimTay View Post
    thats the whole point of them! there not there for show lol

    0170 can be caused by several things 1 being faulty lambdas

    if i was a betting man the rear sensor is all you will need! lee gsi was saying the same so did someone else i think!
    Will Try Both Sensors Before The CAT Then Mate

    Cross You Fingers And Your Goolies For Me

    So When They Diddy`s At Kwikfit Said CAT Was ******..They Are At The Madam ?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermittent Lambda ?
    By JagRigger in forum Engine & Drivetrain
    Replies: 19
    Last Post: 6th January 2013, 08:11
  2. Lambda sensors...
    By nikroc in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th November 2012, 21:56
  3. EML 2.0T Lambda or CAT
    By a1ant in forum Vectra C / Signum Troubleshooting
    Replies: 11
    Last Post: 20th August 2011, 20:53
  4. Lambda help
    By Barnes in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 28th January 2010, 20:42
  5. Lambda
    By VECTRAMAN in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 14th January 2009, 10:33

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •