User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Vectra cdti 150 power loss and miss fire help please

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra cdti 150 power loss and miss fire help please

    hi about three months ago i brought a 56 plate 90,000 cdti 150 estate that after three weeks broke down and ive only just got running again after fitting the following parts:
    Diesel pump (Recon unit)
    4 recon injectors (been reprogramed)
    New DPF
    New Turbo
    New Inlet manifold
    New pressure reg
    New Pressure sensor
    3rd injector wiring
    New fuel Filter

    Basicy i took it to the local garage and it was diagnosed with low fuel pressure. Kept coming up with pressure reg fault, the pump died and one of the injectors was stuck open so changed them all.

    My problem is it still has a missfire at tick over and has little power and after a mile or less eml light comes on and struggles to do 60mph goes into limp mode! turn engine off while driving and back on it goes and then seconds later comes back on.

    Really need help as the car has nearly broke me and having to do my self as can no longer afford garage costs anymore.

    would an egr cause this ive took it to bits and cleaned but no difference?

    ive also cleaned the boost sensor.

    any help would greatfully be recived
    Thanks
    Chris

  2. #2
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anybody???

  3. #3
    Regular Member mcpitman's Avatar
    Join Date
    May 2011
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : 1.9 CDTi

    Year : 2004

    Default

    Morning,

    Have you had the car on any form of diagnostics?

    Or do any of the parts you have had fitted need mapping to the car (via Tech-2)?

  4. #4
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Looking at the list of things you have replaced and noticing that you will still have the old EGR valve on this would be my first port of call for sure - they should be at least cleaned with a new manifold fitted.

    Quickest method would be to blank it temporarily and see if this sorts the issues, if it does then you'll know what it is and can either replace/clean etc.

  5. #5
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers I've ordered a new one so will try it and update you all. Thanks for the replys.
    All parts have been programmed apart from dpf as it failed half way through as elm light came on. Need to sort before it will regen correctly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Miss fire at 1500rpm on my 120 cdti
    By rob10 in forum Diesel Engine related
    Replies: 24
    Last Post: 29th June 2013, 23:37
  2. Vectra sxi 1.8 16v won't rev. Miss fire. Helpp
    By Arran1993 in forum Engine & Drivetrain
    Replies: 40
    Last Post: 31st October 2012, 19:49
  3. Power Loss Vectra V6 3.0 CDTI
    By renwich in forum Y & Z30DT Specific
    Replies: 32
    Last Post: 7th September 2011, 22:52
  4. Vectra CDTi 150 - Loss of Power
    By Chappers. in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th January 2011, 23:37
  5. loss of power miss fire
    By basemanlee in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 6th April 2010, 20:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •