User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Engine Managment Light Help

  1. #1
    Regular Member Telboy's Avatar
    Join Date
    Apr 2006
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine Managment Light Help

    My engine management light on my z22se engine came on yesterday but the car is still running 100% fine. It came on a few weeks back but after dropping it into my mates garage he hooked it up and cleared it off as it was not showing any faults and all for the price of some chocy biscuits.This time I have tried the method on here to show faults but there are none coming up.I have trauled on here using the search and am begining to wonder if its the egr valve playing up and throwing the light on then clearing itself. Might get me some redex and try that.If this is the case how do I get the light to go out or will it just clear itself off after a certain milage or startups. Tickover is fine but on initiall startup She tends to be a little hesitant for first min to rev up clean when pulling out the garage. Can anyone shed any light on this as I would like to sort this out asap with.I know she is running ok but need to try sort it out to clear the light without a gargae visit.Also does anyone on here know if these fault readers are any good and do they clear the eml light after as well,its the U480 model.Any help is greatfuly received as about ready to jack the vectra in and get a Ford Focus ST so things are bad lol

  2. #2
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    On the phone at the moment, give us an hour and I'll go through it with you mate.

  3. #3
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Right where were we.

    The pedal trick doesn't work on the 2.2 mate, so a reader is your best option.

    Without the code then it could be anything but if you think it may be the EGR then its easily and cheaply solved on the 2.2 petrol.



    First get it unbolted and check its working properly by passing 12v through pin's A & E, it should move freely like mine in THIS vid. If not give it a clean, pop it back on and take it for a spin.

    If its sticking and wont move freely after cleaning then its shafted, so a new one £££ or completely take it out of the system with Tech 2 and a blanking plate from the dealers (mega £££), or an EGR cheater and blanking plate from the 2.2 forum HERE You'll probably find the blanking plate alone cheaper at the dealers but you can only buy the cheater from the 2.2 forum.

    Steve

  4. #4
    Regular Member Telboy's Avatar
    Join Date
    Apr 2006
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for that Steve very much appreciated, had an idea you'd come up with the answer for me. Does it mater which pin positive goes on as will have a look this week. Going to look at the U480 fault code reader on ebay and get one ordered up as well, about time I got one them at least I know whats going on.

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    TBH I cant remember, I dont think it matters. Never used a code reader so couldn't advise on which to look at mate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine managment light
    By patch22 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 22nd June 2011, 22:52
  2. Engine Managment Light
    By zealot210 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 30th June 2010, 11:58
  3. Engine managment light???????
    By Deano.56 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 14th December 2009, 18:43
  4. Engine Managment Light, Help!!!!
    By whatthevecisup in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 12th April 2008, 22:29
  5. engine managment light?
    By tonytaxi in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 20th June 2007, 07:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •