User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: engine revs dropping when cold 03 2.2DTI

  1. #1
    New Member
    Join Date
    Jun 2011
    Location
    maidenhead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question engine revs dropping when cold 03 2.2DTI

    recently bought 03 2.2DTI vectra elegance. When started from cold and trying to accelerate the revs start to climb normally and then suddenly and repeatedly drop sharply only to recover immediately. Problem goes away when engine warms up. have checked egr, throttle body and pipes - all seem Ok. Turbo whistling quite sweetly. No fault lights. Any clues anybody?

  2. #2
    Regular Member
    Join Date
    Aug 2008
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just dealing with a similar probelm on an 03 2.2dti Signum. Starts ok, runs about half a mile then virtually cuts out, eml comes on. Sit in car letting it idle, wont rev, but when warm its no problem?
    Only fault logged is EGR but that 'shouldnt' cause the problem. Only query is that is was services just 2 weeks before I bought it including a fuel filter.... Maybe connected

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Revs Dropping
    By mikeq in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 30th January 2011, 18:52
  2. revs not dropping when changing gear
    By billpayer in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 5th January 2010, 12:36
  3. revs dropping and dying out
    By keef2610 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 18th April 2009, 12:16
  4. 2.2DTI - Revs drop and engine cuts out
    By altheman2004 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 28th November 2008, 20:55
  5. 01 Vec B 2.2dti cold start no revs!
    By tommoturbo in forum Engine & Drivetrain
    Replies: 0
    Last Post: 31st January 2008, 05:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •