User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: z18xer temp gauge problem

  1. #1
    Regular Member amd's Avatar
    Join Date
    Oct 2009
    Location
    Lithuania
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default z18xer temp gauge problem

    Hello,

    i think my speedometer temp gauge is broken or smth like that, cause it rises till ~92 normaly, and then stops and dont move more even, when real cooland temp is 110 degree :/
    Real temp i see on BC.
    And another think is, that ventilator starts when temp rise to 110C and stops ~100C is it normal?

    Thanks

  2. #2
    Regular Member
    Join Date
    Jul 2010
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi,

    I also have a Z18XER engine. Although the dash gauge reads 92-93 degrees apparently our engine actually runs at a higher temp (>100 degrees), its something to do with the electronic map operated thermostat these engines have. From what I have read on the net this is perfectly normal for our engines but opel/vauxhall set it so the gauge to read 90-93 degrees to stop vvt owners worrying about overheating engines!

    I havent checked my actual coolant temp compared to the gauge temp but thats the info I stumbled across on the net.

    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. temp gauge problem or not ?
    By madmark in forum Vectra C / Signum Troubleshooting
    Replies: 14
    Last Post: 29th January 2013, 22:27
  2. 2.2 se water pump/ temp gauge problem.
    By james chambers in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th June 2012, 20:31
  3. 2.2 se water pump/ temp gauge problem.
    By james chambers in forum Engine & Drivetrain
    Replies: 15
    Last Post: 19th January 2012, 02:13
  4. rev counter/speedo/temp gauge/fuel gauge stopped working
    By bloodworm in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 19th July 2009, 00:28
  5. Temp gauge problem?????
    By stubopvectra in forum Engine & Drivetrain
    Replies: 4
    Last Post: 4th March 2008, 21:31

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •