User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: who as a dump valve fitted to there veccie turbo z20net

  1. #1
    Regular Member
    Join Date
    Apr 2010
    Location
    Worksop
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default who as a dump valve fitted to there veccie turbo z20net

    as ive seen mixed reveiws

  2. #2
    Regular Member benholden2010's Avatar
    Join Date
    Oct 2010
    Location
    middlesbrough
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Haven't heard of anyone with one on here. The z20net has a recirculating valve and apparently fitting a standard dump valve will make you loose power.

    I'm sure someone else knows abit more about them than me but there pretty much a no go I think

  3. #3
    Regular Member
    Join Date
    Apr 2010
    Location
    Worksop
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Don't think forge supply the kits anymore

  4. #4
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Correct from what I have gained from the site is that the engine itself already has a recirc valve, and fitting an aftermarket one causes/can cause issues

  5. #5
    Regular Member
    Join Date
    Apr 2010
    Location
    Worksop
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah it as but u can blank it off and fit a aftermarket one

  6. #6
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    So if you know the answer already are you just trying to source one?

  7. #7
    Regular Member
    Join Date
    Apr 2010
    Location
    Worksop
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by accveccysriturbo View Post
    So if you know the answer already are you just trying to source one?
    Yes bud were wondering wot needs doing to fit etc and were vac pipes need swapping etc

  8. #8
    Regular Member
    Join Date
    Feb 2011
    Location
    leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  9. #9
    Regular Member
    Join Date
    Jul 2010
    Location
    Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    There may be a good reason why it re-circs.. I know on the Vag 20vt engines its to help with AFR's etc. The Maf sensor can get all upset if it doesnt see the recirculated air come back in..

    Not sure if it is in the same with the z20net's though..

  10. #10
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The boost recirculates in order to keep the turbo spinning: When you back off the accelerator, instead of the unwanted boost "braking" the turbo, or being dumped to atmosphere (dump valve), the boost bypasses the cylinders but keeps the turbo spinning, so that when you press the accelerator again the turbo doesn't have to spool all the way up again. I can't see how disabling this system and instead dumping the boost is going to help.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z20NET and a dump-valve
    By hog in forum Engine & Drivetrain
    Replies: 3
    Last Post: 16th June 2012, 17:34
  2. Dump valve fitting z20net
    By tomo41 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 14th July 2011, 13:14
  3. How many sensors from turbo back on a z20net veccie
    By tomo41 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 30th June 2011, 19:03
  4. Dump valve fitting help on z20net
    By ROCKATANSKY in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 20th September 2010, 21:47
  5. Z20net dump valve Help!!!!
    By dansis in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 6th July 2010, 14:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •