User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 2.0 DTi oil overfilled....now I'm significanltly down on power....

  1. #1
    New Member
    Join Date
    Sep 2008
    Location
    Preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 DTi oil overfilled....now I'm significanltly down on power....

    Hi folks,

    Like a complete plank I overfilled my 2.0 Dti with 10W40 oil and ran the car on a 100 mile round trip on the motorway before draining the oil to the correct level. It turns out I put in about 1 litre too much (about an inch on the dipstick).The yellow engine management light (car with spanner through it) popped up on the way home. After draining the oil to the correct level I have driven to work twice (each time is a 80 mile motorway journey) and the engine management light has popped up a few times for less than 30 seconds. I figure this is the exhaust clearing itself or something.

    The problem… the car is significantly down on power, I don’t know if it is the turbo not working, gunge in the fuel filter…who knows….Does anyone have any thoughts? The car will get to motorway speeds but not very quickly, acceleration is down. Revving the engine out of gear seems to be OK and it will climb the rev range quickly to the 5000rpm.

    Also as an aside I ran the car on 5W30 last year and other than being a bit smelly/smokey all ran fine. Could the oil change have any part in this?

    Thanks Folks.

    James

  2. #2
    Regular Member matt.d's Avatar
    Join Date
    May 2011
    Location
    gravesend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : breeze

    Engine : 1.8 16v petrol

    Year : 2005

    Default

    clean out your egr valve too reckon this could be sooted up due to the engine burning oil

  3. #3
    New Member
    Join Date
    Jun 2010
    Location
    Forfar Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This is maybe a long shot but I had a similar fault after changing oil on a Mazda 6 2.0 tdi. After a few weeks the particulate filter light (DPF) came on and power loss. Had to go to diesel expert and he said common on Mazdas and he is going to do a "burn test" where he runs car at fast idle for 60 minutes and resets light. Semms to have worked, if not new particulate filter.

  4. #4
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    67 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    The 2.o Dti doesn't have a particulate filter

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  5. #5
    New Member
    Join Date
    Sep 2008
    Location
    Preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the egr valve idea, will tryand make some time at the weekend. I helped my father in law clean out the egr on his x-type, that was seriously sooted up and made a world of a difference to performance. My Veccy really only does motorway millage at 300 miles per week ( for the last 40,000 miles), would it be likely that my egr needs a clean out? I guess using the thinner oil last year may make it more likely....what do you guys think? Millage of teh car sits at 75,000.

    Cheers

    James

  6. #6
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The 2.0 dti and 2.2dti its a know problem if oil drops to low or you overfill it afects the powewr of the engine.

  7. #7
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe worth cleaning out the intercooler plumbing and breather pipes?

  8. #8
    New Member
    Join Date
    Sep 2008
    Location
    Preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default plank alert!

    Thought I would give you a quick update and ask another question.....
    I removed the EGR assemby and gave it a good clean. In fact the valve was OK, it was the manifold bits directly above the valve which were gunked up. All nice and clean now. When screwing everything back together i noticed the vacuum pipe which links into a bit of kit situated abovet the top right edge of the radiator was split. In fact i followed this to the other end which connects to the air filter assumbly and noticed that it was not connected at all! Like a plank i must have knocked it off when I changed the filter last week. Repaired the split and reconnected the air filter end.... So the veccy is driving like a dream now, i have not felt it drive as well for a long time. so very happy.

    My question is what does the vacuum pipe do and what is the assembly that it connects to on top of the rad?

    Oh and I also cleaned up the sensor in the egr manifold assembly, it was dripping wet with oil and other muck. I take it that this was what was probably giving me eml issues.

    Cheers guys

    James

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Oil Overfilled by Kwik Fit, Advice needed!
    By veccy101 in forum Vectra C / Signum Car Chat
    Replies: 27
    Last Post: 4th February 2012, 17:00
  2. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 5th June 2011, 11:30
  3. Overfilled the engine with oil
    By whelp in forum Engine & Drivetrain
    Replies: 12
    Last Post: 30th April 2011, 21:46
  4. Overfilled with oil
    By tjsignum in forum Engine & Drivetrain
    Replies: 10
    Last Post: 9th March 2009, 22:06
  5. Overfilled Oil on 2.8
    By Raze in forum Engine & Drivetrain
    Replies: 6
    Last Post: 8th October 2008, 06:43

Visitors found this page by searching for:

what oil to pit in a dti 2 litre vectra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •