User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 3.0 V6 CDTI AUTO - Limp mode, car/spanner warning light

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 3.0 V6 CDTI AUTO - Limp mode, car/spanner warning light

    Hi all, I just bought a signum design 3.0 diesel last week.

    Today the car went into limp mode and I got the car with spanner warning light and almost total loss of power whilst travelling down the motorway at 70mph... scary!

    After turning the car off/on again the warning light has gone and it is now running a bit better, however the car idles roughly and surges / misfires on light throttle around 1500 to 2000rpm.

    I have spent a fair chunk of the day reading the forums and internet sites... seems like this is a common fault for this model of car and could be caused by an endless list of dodgy parts. It is also worrying how many problems these cars seem to suffer from in general!

    Can anyone give me any tips on where to start looking first off?

    I'm tempted to take the car back to the trader who I bought from and demand a refund to be honest.... but I genuinely like the car and it is so comfortable.

    Any advice is greatly appreciated.

    Thanks

  2. #2
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes, this seems to be a new problem a few of us have started to suffer recently
    As above, you lose all power, enters safe mode, and you cannot accelerate

    Have you had the EMS update (field Remedy 1957)?

    I am wondering if this update is also responsible for the increased black smoke that we are also seeing, as my car never had this before
    I suspect the EMS is applying a process to clean out the SCV at regular intervals, causing the black smoke, as once this phase has passed there is no more black smoke for several weeks

    Mine has done it twice now
    Once the engine is warm, loads of black smoke when downshifting (typically 5th or 6th gear to 2nd or 3rd gear)
    Once this process has ended the engine goes into safe mode
    Stop the car, remove the ignition key, wait 5 minutes, restart

    Also, I have noticed the amount of black smoke has started to increase again, so am expecting this to happen again in the next few days

  3. #3
    Regular Member
    Join Date
    Jun 2011
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by m8internet View Post
    Yes, this seems to be a new problem a few of us have started to suffer recently
    As above, you lose all power, enters safe mode, and you cannot accelerate

    Have you had the EMS update (field Remedy 1957)?
    I have no idea . I don't know much about these cars as I've only had it a few days.

    What I can say is losing all power is ****** scary on the motorway.

    To be honest if I had done a bit more research before buying I probably wouldn't have.
    It seems like these engines are plagued with problems.... but now I'm stuck with it, so I'm just wondering where to start looking really.

    I don't fancy paying nigh on £200 for some monkey at Vauxhall to plug it into a laptop and read out the codes (which may not exist since the light as now gone out again).... but I guess I may have no choice!

  4. #4
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Bigv View Post
    It seems like these engines are plagued with problems.... but now I'm stuck with it, so I'm just wondering where to start looking really.

    I don't fancy paying nigh on £200 for some monkey at Vauxhall to plug it into a laptop and read out the codes (which may not exist since the light as now gone out again).... but I guess I may have no choice!
    The 3.0 V6 CDTI is incredibly reliable, it is the most reliable I have had so far
    However, when it does go wrong VX seems to scratch their heads and when they do finally find out what is wrong it ain't cheap (but neither are most modern engines now)

    There shouldn't be a charge of £200 for a TECH2 check and report, no more than £80
    Get some quotes for such a check
    However, the code will need to be stored, so best wait until it is permanent
    Next time it occurs drive the car straight there, leave the engine running and advise them it has the fault

    Finally, look at a third party warranty
    The AA cover is excellent
    If there is a fault code then the claim should cover this

  5. #5
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : Z19DTH

    Year : 2004

    Mileage : 172000

    Default

    im sure there will be a fellow member near you that has a diagnostic device, if not you can get them of ebay very cheap and will save you a fortune over the time you have the car

    Have a good llok at the hoses for any splits or holes.

    good luck

  6. #6
    Regular Member
    Join Date
    Jun 2011
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by neill View Post
    im sure there will be a fellow member near you that has a diagnostic device, if not you can get them of ebay very cheap and will save you a fortune over the time you have the car

    Have a good llok at the hoses for any splits or holes.

    good luck
    Hi, I have checked for split vaccum hoses or pipes (which are usual faults with turbo motors I guess)

    Anyway, could anyone recommend a fault code reader / diagnostic scanner on ebay that is worth getting? I know some are good and others are a bit pants.

    I was looking at this one: http://cgi.ebay.co.uk/DIAGNOSTIC-FAU...item35b0ea56f6

    ??

  7. #7
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : Z19DTH

    Year : 2004

    Mileage : 172000

    Default

    thats what i use and you can do so much with it, ideal for fault reading and clearing, key progrmming etc

    i would recomend one of these to any vaux owner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 CDTI Turbo Whine and ECM02345a spanner light + limp mode
    By wakey1512 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 4th August 2012, 20:18
  2. Spanner Light but no Limp Mode
    By GazVXLINE170 in forum Vectra C / Signum Car Chat
    Replies: 31
    Last Post: 28th July 2010, 13:07
  3. limp home mode but no spanner light??
    By mick 1986 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 5th April 2009, 12:22
  4. Replies: 33
    Last Post: 30th December 2008, 19:08
  5. spanner light on 2.2 dti and goes in to limp mode
    By thelad in forum Engine & Drivetrain
    Replies: 7
    Last Post: 14th March 2008, 21:48

Visitors found this page by searching for:

vectra car with spanner warning light

https:www.vectra-c.comforumshowthread.php140493-3-0-V6-CDTI-AUTO-Limp-mode-car-spanner-warning-light

vauxhall signum engine management light v6 automatic limp mode

vectra going into limp mode v6 2005

vauxhall vectra 3.0 diesel keeps going into safe mode

vectra c 3.0 cdti light with spanner

vectra v6 spanner light with traction what does it mean

Car vauxhall signum 3.0 v6 goes into limp mode when trying to funeral throttle diesel

vectra v6cdti spanner light stsys on

vectra c v6 cdti engine light

3.0 d vauxhall limp mode every time

signum diesel limp mode

spanner and car warning light on vectra c

vauxhall vectra 3.0 cdti light

car started and went in to limp mode. car with spanner light is on

vectra v6 in limp mode

vectra v6 3.0 2005 warning lights

vectra 3.0 diesel black smoke

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •