User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Loss of power diagnosis Vectra 1.9 CDti

  1. #1
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Loss of power diagnosis Vectra 1.9 CDti

    Just had the codes read by my local independent Vauxhall garage due to serious lack of power below 2500 revs (feels like I'm driving a truck) don't know the exact codes that came back as I forgot to write them down but as I remember the codes that were revealed were I think:

    • Swirl Actuator Supply Voltage Range/Performance
    • Injector Circuit Open / Shorted - Cylinder #1
    • Injector Circuit Open / Shorted - Cylinder #3




    .....and something to do with the EGR but this has been newly replaced so hopefully not an issue.

    Does this sound like an electrical issue with the injectors as it hasn't had the mod done yet.

    Thanks

    Matt

  2. #2
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Please Help

    Thanks

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Looks to me - and I may be wrong - that you need a new inlet manifold.
    Now I need a turbo to keep up!

  4. #4
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just had it replaced mate

  5. #5
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The power was there prior to having the Inlet Manifold, Swirl Actuator, Water Pump, Timing Belt and Throttle Body replaced. But now....nothing.

  6. #6
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did they change the actuator? Have you looked to see if it operates correctly?
    Now I need a turbo to keep up!

  7. #7
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I hope so, I paid for it to be replaced :s How do I know if its working correctly?

    Thanks

  8. #8
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Look at it and get someone to turn the ignition on. IIRC it will do a self test. Check for full range of motion.

    If you have had it all replaced recently, are these present or stored codes?
    Now I need a turbo to keep up!

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i'd go for EGR valve ! even though you have codes

  10. #10
    Regular Member
    Join Date
    May 2011
    Location
    Dishforth, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok, I'll get that checked to see if everything is working as it should be. The EGR valve has been replaced only 1 month a go.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra 3.0 sri cdti: 75 % power loss. No inection
    By mtqn in forum Engine & Drivetrain
    Replies: 19
    Last Post: 27th June 2012, 23:47
  2. Power Loss Vectra V6 3.0 CDTI
    By renwich in forum Y & Z30DT Specific
    Replies: 32
    Last Post: 7th September 2011, 22:52
  3. Vectra c 3.0 cdti ( loss of power )
    By dshelton999 in forum Engine & Drivetrain
    Replies: 22
    Last Post: 22nd June 2011, 20:58
  4. Help with Vectra CDTI SRI 150 - Car loss of power
    By dan912 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 27th May 2011, 08:59
  5. Vectra CDTi 150 - Loss of Power
    By Chappers. in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th January 2011, 23:37

Visitors found this page by searching for:

vectra c cdti loss of turbo power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •