User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: CDTi 150 Power Problems

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CDTi 150 Power Problems

    Hi,

    I am after some advice, i have a 150 CDTi and it seems to lack power below 2000-2500rpm, and also has a loud whistling noise when driving or even when stood and engine is revved up, it whistles then as u let off throttle it like whooshs, and am tad confused as to what to do next

    So far this week i have fitted a new thermostat as the old one was stuck open, and i have also fitted a new inlet manifold and the old one was shot, and at the same time i partially blanked the egr, cleaned out the egr valve and throttle body, and fitted a new timing belt and water pump at the same time, so all in all been a busy week to find that even tho my linkage had come off my swirls it is not the reason i get power and noise issues.....

    any advice anyone please before i give up hope and sell it

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    EGR valve or turbo vacuum pipes.

  3. #3
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    forgot to mention i replace most of the turbo vac pipes with silicone ones today too, and the egr valve was stripped down, taken apart and cleaned..... am lost

  4. #4
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by sclarkson82 View Post
    forgot to mention i replace most of the turbo vac pipes with silicone ones today too, and the egr valve was stripped down, taken apart and cleaned..... am lost

    Still say the EGR valve is the culprit. Mine was stripped down and cleaned but still didn't function properly.

    If you happen to confirm whether the EGR valve is functioning or not, my next port of call would be the fuel filter, then get the injectors leak off tested.

  5. #5
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    funny u should say that but i have a genuine fuel filter in the boot, along with my oil and oil filter, got them at the same time as all the other bits, but ran out of day light yesterday and then wen i road tested it this morning i lost interest, are fuel filters likely to cause low down power problems tho...... would have thought it would cause total power loss not just low revs

  6. #6
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by sclarkson82 View Post
    funny u should say that but i have a genuine fuel filter in the boot, along with my oil and oil filter, got them at the same time as all the other bits, but ran out of day light yesterday and then wen i road tested it this morning i lost interest, are fuel filters likely to cause low down power problems tho...... would have thought it would cause total power loss not just low revs

    They can and they are more like to make a low down problem seem even worse, usually this causes juddering but I am only pointing this way if all the other ones are out.

    Other less serious reason could be the ECU needs an update. I have a minor hesitation I can't shift. The problems you describe point to an EGR valve if the engine actually lacks the power badly as that is a common EGR valve fault symptom.

  7. #7
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my manifold was full of crud..... but a i have partially blanked the egr..... might totally blank it and see wat happens..... seems like i have overboost or a boost leak with noise it makes..... could it be boost sensor as that was coked up solid

  8. #8
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by sclarkson82 View Post
    my manifold was full of crud..... but a i have partially blanked the egr..... might totally blank it and see wat happens..... seems like i have overboost or a boost leak with noise it makes..... could it be boost sensor as that was coked up solid
    Yip they coke up bad.

    First of all m8 start eliminating each possiblity you can one by one. It could be anything but as I keep saying EGR valve. At the very least as you actually have some sort of problem and need to eliminate the EGR valve then blank it off. If the car still does it then you know the EGR valve is fine and you can move onto the next problem.

    I may concede defeat with Dan Black Sri - if that valve is the problem - may be the sodding valve is just a plain nuisance, may be it would be better if we just removed the most probable root of our issues as CDTI owners.

  9. #9
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    u not think it could be boost sensor ???
    are the any usual places i could get a boost leak ???

  10. #10
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by sclarkson82 View Post
    u not think it could be boost sensor ???
    are the any usual places i could get a boost leak ???
    Take it off and have a look, like I say they get gunked up but if the manifolds been changed recently it might be ok.

    Boost leaks are common at the intercooler pipes and the plastic pipe that leaves the MAF and heads down to the turbo - it can split on the bend.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. power problems
    By DavieVectd120 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 26th January 2011, 17:21
  2. 1.9 CDTi loss of power problems
    By misterpants in forum Engine & Drivetrain
    Replies: 23
    Last Post: 12th November 2010, 00:24
  3. 1.9 cdti auto problems problems
    By trigger in forum Engine & Drivetrain
    Replies: 2
    Last Post: 28th September 2009, 17:20
  4. Power problems
    By gibbon7000 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th April 2009, 10:28
  5. 150 CDTI Power Problems
    By multi in forum Engine & Drivetrain
    Replies: 6
    Last Post: 12th January 2009, 19:58

Visitors found this page by searching for:

55 vectra 1.9 cdti whistling noise when driving and loss of power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •