User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 3.0 v6 cdti 2004 lack of power

  1. #1
    Regular Member DONNAS5889's Avatar
    Join Date
    Jun 2011
    Location
    atherton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 3.0 v6 cdti 2004 lack of power

    CAN SOMEBODY PLLLEEEASSSE OFFER ANY ADVICE....serious lack of power in all gears, when asking for the performance the engine refuses, the car will then catch up on itself and kicks like a mule!!!! I have had a new EGR fitted but I am still experiencing the same problem. I have fallen head over heels with this car and would like to rectify the problem

  2. #2
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Take the top off the fuel filter and see how much is in there mate - there's no pump in the tank and it's worked purely off the suction form the engine's pumps.

    If there's too much air in the filter housing due to a leaking seal or the like then it'll just suck more in as time goes by and the fuel starvation gets worse. If you take the top off, fill the housing back up and stick the top back on, be very careful when restarting because if you start it and don't rev it a bit then it'll suck in air and stall...

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Any warning lights? Mine did it when stood for a while but freed up after an Italian tune up. I think mine was the variable vanes in the turbo sticking.
    Now I need a turbo to keep up!

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Sounds like the problem I had on my old 3.0CDTi. Was variable vanes in the turbo sticking...Kicked in at 3000rpm...was dead below 2500...and like you I had a new EGR fitted.

  5. #5
    Regular Member DONNAS5889's Avatar
    Join Date
    Jun 2011
    Location
    atherton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ref fuel filter, changed it, cracked housing in process new one fitted. Its just so frustrating as the car wants to please, the power is there its just being held back, turbo is getting the treatment next, does anybody think it could be contamination??? I am running out of ideas fast.....

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Try fitting a new mass air flow sensor. That was causing some problems to my 3.0 too...could be that as well...

  7. #7
    Regular Member DONNAS5889's Avatar
    Join Date
    Jun 2011
    Location
    atherton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have only had car a couple of months is there a recommended site for parts, instead of trawling through the thousands of them. Is the turbo job garage only or is it achievable under my own steam...many thanks for the advice though, thought I was the only one out here!!!!!

  8. #8
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    The mechanic that replaced my turbo (just needed its vanes to be cleaned, but I got a new turbo very cheap) took 4h to remove the old turbo and fit the new one...He's a very skillful mechanic with a lot of tools, yet we still had to break a spanner in half to access a bolt on the exhaust manifold. I would not attempt this myself even if I had all the appropriate tools.

    Good luck with finding a brave mechanic mate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C 150 CDTi Lack of Power
    By sclarkson82 in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 18th March 2011, 21:07
  2. Help needed Lack of Low Down Power cDTI 150
    By supersione in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 24th January 2010, 19:58
  3. Lack Of Power (2004 1.9 cdti 8V)
    By user999998 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd June 2009, 09:03
  4. cdti 150 lack of power
    By michael cummings in forum Diesel Engine related
    Replies: 3
    Last Post: 8th February 2009, 20:44
  5. 1.9 cdti sri whine on start, int lack of power
    By kojak01 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 21st February 2007, 08:47

Visitors found this page by searching for:

3.0 v6 cdti no revs site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •