User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Vectra not starting / battery light

  1. #1
    Regular Member
    Join Date
    Aug 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra not starting / battery light

    Hi,
    Just after a quick bit of advice!

    My car has been drivable for the past few days with the battery light coming on every now and again, although yesterday it failed quite badly, power steering, radio etc all died, left it a while and managed to get it home.

    Later on I checked the battery the LED light is dead it's just black, so I decided to put a multimeter across it and it read 11.1v, then I started it down to 10v revved to fast idle 10.5v.


    I'm assuming new battery and alternator, although I have read that once that green light is out the alternator no longer charges the battery.

    Thanks for any help
    Graham

  2. #2
    Regular Member marktaylor's Avatar
    Join Date
    Dec 2009
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by graham22vti View Post
    Hi,
    Just after a quick bit of advice!

    My car has been drivable for the past few days with the battery light coming on every now and again, although yesterday it failed quite badly, power steering, radio etc all died, left it a while and managed to get it home.

    Later on I checked the battery the LED light is dead it's just black, so I decided to put a multimeter across it and it read 11.1v, then I started it down to 10v revved to fast idle 10.5v.


    I'm assuming new battery and alternator, although I have read that once that green light is out the alternator no longer charges the battery.

    Thanks for any help
    Graham

    looks like a new alternator for you im afraid

    battery may be ok your best waiting to see if a new alternator will charge it back up before buying a new one

  3. #3
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    New alternator and possibly battery mate.

  4. #4
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Quote Originally Posted by marktaylor View Post
    looks like a new alternator for you im afraid
    Quote Originally Posted by byebyeitsagsi View Post
    New alternator

    Yup agreed, defiantly the alternator, should be 13.5-14.4v with the engine running.

  5. #5
    Regular Member
    Join Date
    Aug 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I was just speaking to a mate who is an ex mechanic and he said it may well just be the battery due to car batteries not charging if the health light is out.

    I had the battery on charge all last night from 19:00 and it still wasn't charged this morning at 8.00.

    I know it's more than lightly the alternator worse thing is the alternator was replaced not long before I bought it.

    Thanks
    Graham

  6. #6
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    When you say it wasn't charged this morning were you just going by the green light on the battery? I flattened my last battery by having the stereo on all day when cleaning my car and it took a couple of days for the green light to come back properly. Even if the battery is duff you should still get 13.5-14.4 volts at the terminals with the engine running.

  7. #7
    Regular Member
    Join Date
    Aug 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The battery charger has a charging light on it, it switches off once fully charged.

    Anyone know where to get a cheap alternator

  8. #8
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. starting poor, battery advice?
    By rozzer2006 in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 15th December 2012, 22:05
  2. Battery light on 5 minutes after starting
    By SlowCoach in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 4th December 2012, 10:24
  3. Battery Light ON - 14.1 volts at battery
    By snapsnap in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 6th December 2011, 13:55
  4. Vectra battery light occasionally coming on
    By Mark Curran in forum Engine & Drivetrain
    Replies: 10
    Last Post: 2nd August 2011, 17:37
  5. Car not starting, battery issues??
    By Adz86 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 5th November 2009, 08:57

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •