User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: loss of power then sounded like the exhaust had been took off

  1. #1
    Regular Member coooky's Avatar
    Join Date
    May 2011
    Location
    washington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default loss of power then sounded like the exhaust had been took off

    driving my car back from the supermarket it lost a lot of power and was sluggish then it started to sound really loud noise luckily i was only a short distance from home and managed to drive it back slowly

    i think my turbo has blown would this make the engine sound really rough as if the exhaust has been took off the engine

    car is a cdti sri 150

  2. #2
    Regular Member RobW's Avatar
    Join Date
    Sep 2007
    Location
    Tain - Easter Ross
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check your boost pipes. Sounds to me like one is either loose or split.

  3. #3
    Regular Member coooky's Avatar
    Join Date
    May 2011
    Location
    washington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i hope so fingers crossed

    the wife has called the RAC out to have a look

    when driving this morning it was making a noise like the turbo kicking in but around 3-4 times louder and more like escaping air

  4. #4
    Regular Member coooky's Avatar
    Join Date
    May 2011
    Location
    washington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you were right on the pipe mate

    but it was a snapped egr pipe so im well pleased

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By STRETCH2009. in forum Engine & Drivetrain
    Replies: 6
    Last Post: 8th August 2012, 18:44
  3. Exhaust emission light and loss of power below 2000 revs
    By craigb in forum Engine & Drivetrain
    Replies: 13
    Last Post: 14th March 2011, 15:08
  4. Help with loss of power
    By ALAN B in forum Engine & Drivetrain
    Replies: 10
    Last Post: 4th March 2011, 16:52
  5. loss of power
    By iansfocus in forum Engine & Drivetrain
    Replies: 5
    Last Post: 6th October 2010, 23:37

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •