User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: Vectra C 1.8 SRI (faults?)

  1. #1
    Regular Member
    Join Date
    May 2011
    Location
    STAFFS, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra C 1.8 SRI (faults?)

    Hi ive recently purchased a vectra c 1.8 sri 2003,
    I find its a very nice car but have a few faults.
    1 is that i find it terrible on fuel, on a run the most i can get is 27mpg.
    i find it very expensive to run and dont think this is right, engine has 114k on the clock with full serviec history and cambelt change at 112k by pervious owner, engine is quiet no knocking or tapping.
    I dont have any engine managment light on but really think there is something wrong!.
    the car seems to have no guts at all if im honest and do have a slight rabbit on driving of in 1st sometimes. apart from that it feels pretty smooth.
    Can anybody shine some light on this please?
    thanks tony
    Last edited by daddycool; 10th June 2011 at 15:43.

  2. #2
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Someone else had this issue not long ago, don't think we ever got to the bottom of it. At the moment combined im getting 38mpg, on a run well over 40 mpg. Might be worth checking the condition of the plugs, air filter, fuel filter as a full service history does not mean its actually been serviced.

  3. #3
    Regular Member zafira's Avatar
    Join Date
    Aug 2010
    Location
    North of Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    How long is it since last service? Sparks, oil etc.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What sort of journeys are you doing for that mpg? short trips or long ones? Don't forget its a fairly small engine and a pretty heavy car.
    Now I need a turbo to keep up!

  5. #5
    Regular Member triple595's Avatar
    Join Date
    Mar 2011
    Location
    llandrindod wells
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is the thermostat ok, I'm sure I read on here if the stats knackered it will drink juice

  6. #6
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    for comparison I was getting 420-450 out of a tank but that included a lot of motorway miles. Also I drove it quite hard but used the cruise control were I could.
    The main fault you get is failed thermostats, once warm the engine should stay at 85-90 ish and not drop regardless of conditions. Mine was faulty and would drop as I drove and would hardly move in the winter. I never did get round to changing it so I cannot tell you if it would have improved my mpg.

    I also believe there was clutch issue with the 1.8 which was subject to a recall if I remember or it was a known fault and had a remedy, one or the other.

    To be honest the 1.8 engine should never have been fitted to the Vectra C as the car is too heavy. The 1.8 is ideal in an Astra MK4 where it preforms well (we have one sitting on the drive). The newer 1.8 VVTi is a better engine (140bhp compared to the 122bhp of your engine) but is still a bit under powered for the size of car
    Last edited by merikiito; 10th June 2011 at 18:07.
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  7. #7
    Regular Member triple595's Avatar
    Join Date
    Mar 2011
    Location
    llandrindod wells
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Also if it hasn't been done, do the airbox mod, I found it improved mine no end

  8. #8
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Quote Originally Posted by triple595 View Post
    Also if it hasn't been done, do the airbox mod, I found it improved mine no end
    I fitted the K & N Cone Filter to mine along with a twin exit exhaust
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  9. #9
    Regular Member
    Join Date
    May 2011
    Location
    STAFFS, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ive done a few trips (60mile) and also i do alot of short (10mile) trips. both average at 26-28.
    as far as i no was serviced last year in july 4k ago of which states its had brake fluid,spark plugs,fuel filter,pollen filter,along with cambelt.

    ive checked the air filter and that looks new, oil looks ok. not checked the plugs. but must say the pollen filter is very dirty (maybe they ticked its changed but hasnt).
    the car temp guage is abit strange at times as it at times it just shows nothing "needle hasnt moved".
    but if i start from cold and leave it running never goes over the 80-90 and fan kicks in so i wouldnt a clue if something wrong with thermstat??.

    as for the clutch i do seem to have a problem, clutch peddle feels weird and i can hear noise when engaging the clutch from the pedal, to me the pedal doesnt return fast enough or maybe sticking, but clutch is biting ok and biting point seems ok.

    I do have problems with my brakes, they squeak all the time and it drives me crazy, i had them checked and they said the pads need copper grease so they greased them up (local garage) and they never made a noise for about 5 mile and now the noise bk again.
    maybe the last owner had a problem with the squeaky brakes hence the brake fluid on the last service, "maybe they didnt do it right".

    there my current problems with my car, apart from that its a nice car although i did have to change the suspension springs a day after i purchased this car due to the rear was snapped, but after putting on a set of lowering springs as a replacment car looks rather nice.
    i really hope i can get tot he bottom of these problems and mainly the MPG as its costing me a fortune. trip stats say 210 miles for 10 gallons its used, that is from a mixture of long and short jurneys.

    any help for these problems will be help full.
    Last edited by daddycool; 10th June 2011 at 19:18.

  10. #10
    Regular Member
    Join Date
    Sep 2009
    Location
    Audley STAFFS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    after you have done a longish journey check all the disc's to see if one is getting hot/binding. check the plugs for your self, I found BOSCH Super work well in my none vvt 1.8. as for mpg,, do your own check,ie fill car right up, set trip to zero do say 300 miles of your normal driving, check miles, devide ltrs by 4.546 to give galls used. my car has averaged 38 mpg but does not do city/ rush hour traffic, ONCE I had a week of city/town driving it did 32 mpg so you are not that far off.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Vectra C] [02-08] 03 sri water in foot well but now have many electrical faults
    By gavin1981 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 16th September 2012, 21:51
  2. Vectra C 1.8 2002 CIM and ECU Faults
    By Dougie in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 19th December 2011, 13:41
  3. Im going to view a Vectra 2.2 SRI! any major faults to look for?
    By David P in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 6th July 2011, 19:10
  4. loads of faults on my vectra - HELP
    By molloy in forum Engine & Drivetrain
    Replies: 16
    Last Post: 23rd January 2011, 20:44
  5. vectra- problems or common faults?
    By fergusix in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 1st September 2008, 16:48

Visitors found this page by searching for:

vectra c engine 1.8 faults

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •