User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Brake Light Woes - Can Anyone Help?

  1. #1
    New Member
    Join Date
    May 2011
    Location
    Brackley, Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Brake Light Woes - Can Anyone Help?

    I'm just a keen DIYer btw, but hoping somebody can shed some light on the weirdness I'm getting... My brake lights don't work and I get very occasional problems when starting the engine (Vectra C 1.8 2002)

    On the starting issue - sometimes (but infrequently) when I turn it over it idles roughly/judders and then stalls. Start it again and all's well for the next 10-15 attempts.

    The brake lights are even weirder;they work for 1-5 mins until the MIL comes on, at which point they stop working and won't work anymore until I reset fault codes. I've replaced the pedal switch just in case, checked the fuse and all rear lamps/3rd brake light - everything checks out with a meter. (The brake lights seem to work properly and indefinitely if the engine isn't started, and only stop when the engine's started and the MIL comes on, always giving the two codes below):

    P0170 (Fuel trim)
    P0571 (Brake switch A circuit)

    I reset the MIL before I looked at the fuel trim levels, so am not too sure where to start on the P0170. I'm guessing I should check for leaks/clean the MAF?

    Any help really appreciated - I've been tearing my hair out over this (and can't afford to lose what precious little I have left

  2. #2
    Regional Organiser - East Region whiskyno7's Avatar
    Join Date
    Mar 2010
    Location
    norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall signum

    Trim : 2.0t

    Engine : chipped and remapped

    Year : 03

    Mileage : 100k+

    Default

    mass air flow/ and egr valve sound like how mine was till i got mine sorted out. but lights ??? cant help sorry
    it say's it all

  3. #3
    New Member
    Join Date
    May 2011
    Location
    Brackley, Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Crikey! - I thought my post was a bit late in the day but thanks for the pointer

  4. #4
    New Member
    Join Date
    May 2011
    Location
    Brackley, Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Update: A clean of the MAF sensor wires cleared the P0170, but brake light still triggering an error (but only with engine running after a variable few minutes). I'm guessing an intermittent short/break caused by engine vibration in the loom somewhere. That'll be fun to find if it is...

  5. #5
    VIP-Member
    Join Date
    Jun 2010
    Location
    `
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : `

    Trim : `

    Engine : `

    Year : `

    Mileage : `

    Default

    See if you can find the earth for the lights and give it a good clean. Id even pull the fuses and check theres not a bit of corrosion on them, long shot I know but thats whered id start.
    "We are not some sort of dictatorship!"


  6. #6
    New Member
    Join Date
    May 2011
    Location
    Brackley, Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ...anything's worth a go right now - cheers

  7. #7
    New Member
    Join Date
    May 2011
    Location
    Brackley, Northants
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    After a long day with a wiring diagram (courtesy of a Haynes manual I ordered yesterday from Amazon) and a probe/meter, have finally found the culprit; a loose connector to the passenger side fusebox/control unit (behind the glovebox). Problem sorted (and cruise control working again - it wasn't but raised no fault code other than the brake circuit one).

    Relieved to have it sorted - can't imagine what the bill would have been via VX

  8. #8
    VIP-Member
    Join Date
    Jun 2010
    Location
    `
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : `

    Trim : `

    Engine : `

    Year : `

    Mileage : `

    Default

    Great result. Always satisfying sorting a problem like that.
    "We are not some sort of dictatorship!"


  9. #9
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mokka

    Trim : SE - Orange Rock 's !!

    Engine : 1.7CDTi

    Year : 2014

    Default

    Yes, well done.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake Warning light and display error message , BUT BRAKE LIGHTS ARE WORKING FINE
    By JACKALG1 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 24th May 2013, 18:56
  2. Brake Light Warning Light
    By michaelangelo in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 29th August 2011, 01:31
  3. Side Light woes
    By dwstraining in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 13th September 2010, 16:53
  4. 2.2 Direct emission light woes
    By DysonDog in forum Engine & Drivetrain
    Replies: 0
    Last Post: 7th June 2009, 10:40
  5. Spanner light & 3rd brake light warning?
    By simp_2.2sri in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 5th December 2008, 17:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •