User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: clutch is not springing back correct position

  1. #1
    Regular Member
    Join Date
    Sep 2009
    Location
    newcastle
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default clutch is not springing back correct position

    i was driving on the motorway when i went to drop a gear to slow down a bit the clutch was in the depressed position but not fully down when i pressed the pedal it was still working but very stiff to press i manage to get home and have a look and lifted the pedal back to the correct position and it now seems to be working ok has anyone had this trouble before also there is a noise coming from the release bearing which seems to be getting worse.


    cheers in advance

  2. #2
    Regular Member sebadee's Avatar
    Join Date
    Jan 2011
    Location
    macclesfield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Had a similiar thing with mine where it occasionally stuck down but after a while it totally went turnt out the slave cylinder was shot and leaking fluid
    Not saying that's ways wrong with yours though
    Last edited by sebadee; 30th May 2011 at 21:26. Reason: Edit

  3. #3
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    As above.

    Sounds like the slave cylinder is leaking and now contaminating the bearing/clutch

  4. #4
    Regular Member
    Join Date
    Sep 2009
    Location
    newcastle
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    whats the damage on getting that done with good parts approx

  5. #5
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    About £500-£600

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. These the correct ones?
    By golfpro in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 28th December 2012, 03:06
  2. Clutch slipping and loosing clutch/brake fluid
    By marty_b0y in forum Engine & Drivetrain
    Replies: 15
    Last Post: 31st May 2012, 00:18
  3. how to refit dlc back in position?
    By NIGHTCD in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 5th October 2010, 16:21
  4. Need help with clutch rattle that dissapears when clutch depressed
    By leeroberts919 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th July 2009, 11:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •