User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Help with Vectra CDTI SRI 150 - Car loss of power

  1. #1
    Regular Member
    Join Date
    May 2011
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help with Vectra CDTI SRI 150 - Car loss of power

    My vectra has been running great until the other day, it seems to have lost alot of power. It runs okay for about 15 miniutes then it goes into limp mode and will not seem to rev over 3000. Any ideas?

  2. #2
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by dan912 View Post
    My vectra has been running great until the other day, it seems to have lost alot of power. It runs okay for about 15 miniutes then it goes into limp mode and will not seem to rev over 3000. Any ideas?
    Ive posted in your other thread

  3. #3
    Regular Member
    Join Date
    May 2011
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks, didnt mean to post twice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra 3.0 sri cdti: 75 % power loss. No inection
    By mtqn in forum Engine & Drivetrain
    Replies: 19
    Last Post: 27th June 2012, 23:47
  2. Power Loss Vectra V6 3.0 CDTI
    By renwich in forum Y & Z30DT Specific
    Replies: 32
    Last Post: 7th September 2011, 22:52
  3. Vectra c 3.0 cdti ( loss of power )
    By dshelton999 in forum Engine & Drivetrain
    Replies: 22
    Last Post: 22nd June 2011, 20:58
  4. Loss of power diagnosis Vectra 1.9 CDti
    By MT82LFC in forum Engine & Drivetrain
    Replies: 9
    Last Post: 17th June 2011, 20:58
  5. Vectra CDTi 150 - Loss of Power
    By Chappers. in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th January 2011, 23:37

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •