User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Clicking noise on start up - 2004 Vectra Energy 1.8

  1. #1
    New Member
    Join Date
    Jun 2010
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Clicking noise on start up - 2004 Vectra Energy 1.8

    On start up, there is a clicking noise from the passenger footwell. It clicks 3 times and I wonder if it is the heater?
    Any ideas and how to fix it?

  2. #2
    Regular Member ROCKATANSKY's Avatar
    Join Date
    Apr 2008
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I think you'll find it's the control box that moves the valve on the matrix between hot and cold. If yoiu move it to hot then back to cold then you should hear it each time. Quite common

  3. #3
    New Member
    Join Date
    Jun 2010
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Whats the fix, a new control box?

  4. #4
    Regular Member
    Join Date
    Jul 2010
    Location
    cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same issue. It's the hot cold air circulation servo as I tried to get it replaced under the network Q warranty but no go. Vx then quoted £89.99 for the part plus fitting.
    I think I can live with it for now. There is a How2 about replacing the servo.

  5. #5
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its not necessarily the hot cold servo.

    my clicking was the air recirculating motor. when you switch the ignition on the recirculator motor opens the flap and when you switch the ignition off the flap closes.

    Press your re-circulating button and if it does the noise you know its that.

    A new one is £65 from dealers and £20 from scrappy. Be warned its a sod to take off and harder to put on due to having to work in the foot well.

    The 2nd hand motor I bought broke after a few months so in the end I just unplugged the power supply to the motor and jammed the flap in the open postion with the siezed arm from the motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 14th July 2012, 19:53
  2. Vectra strange clicking/scraping noise
    By Sparkyork in forum Engine & Drivetrain
    Replies: 17
    Last Post: 21st June 2012, 01:36
  3. Vectra will not start 2 clicking sounds......
    By big nath in forum Engine & Drivetrain
    Replies: 11
    Last Post: 28th July 2011, 14:43
  4. Vectra 3.2 05 Gsi clicking noise when ignition turned on/off
    By bignew in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 26th June 2009, 19:36
  5. U480 Code Reader & Vectra 1.9cdti Energy (150) 2004/5
    By markluk in forum Engine & Drivetrain
    Replies: 3
    Last Post: 27th February 2009, 08:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •