User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: GID issues

  1. #1
    Regular Member
    Join Date
    Jul 2009
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default GID issues

    hey all,

    so the GID in my vectra has a few dead pixels, which are starting to bug me. local dealer said that they would have to replace whole setup, to a cost of over $1200 (AUS). which is a bit rich. its just the LCD thats the issues, not the whole system. anyone know when you can get just the LCD part?

  2. #2
    Regular Member cossiejay's Avatar
    Join Date
    Mar 2011
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri 150

    Engine : 1.9 cdti

    Year : 2007

    Default

    i have just sold a perfect one on ebay for £16

  3. #3
    Regular Member blutak's Avatar
    Join Date
    Apr 2011
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When??? ive been looking for one for a month now!

  4. #4
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    if its just the LCD then get one from ebay, then swap over just the LCD. and you will be fine..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A few issues..........
    By matt_6436 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 20th October 2012, 11:15
  2. EGR Issues
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 30th June 2012, 11:51
  3. Issues!
    By Danwells72 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 29th April 2011, 01:13
  4. Would I have any issues with...
    By n_hudson in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 24th August 2008, 19:07
  5. mp3 issues with cd 70
    By jeff_g in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 6th June 2008, 22:27

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •