User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: crankshaft sensor

  1. #1
    Regular Member
    Join Date
    Jun 2007
    Location
    leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default crankshaft sensor

    ok could enyone help before i shell out for an auto electration on tues

    the problem is the spanner light came on so i did the pedal trick and also bought a obd11 scanner and both confirmed it was the crankshaft sensor
    so i replaced cancelled the codes but they came back on again,having looked on here and the net someone had asimular problem and it turned out to be the sensor was not seated properly. so ive just been outside and taken it off again and it was covered in oil ( is this ok) cleaned it put it back in and it all worked ok starting the enguine and stopping it several time when i went to pull the car round the front it came on again

    2 question really

    1 should the sensor be couvered in oil
    2 i onle replaced the sensor could it be the cable that needs replacing

    or any othe ideas

    thanx guys

    p.s 1.8 petrol on a 02 plate

  2. #2
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by valhalla View Post
    1 should the sensor be couvered in oil
    No, there should be no oil
    It is clearly escaping from somewhere so you need to trace it
    The oil is then getting in the way of the sensor, there was probably nothing wrong with the original, so refit that one once you have sourced the oil leak

  3. #3
    Regular Member
    Join Date
    Jun 2010
    Location
    Here
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)

    Default

    Nope, looks like youve an oil leak, maybe from a cam shaft oil seal. When I did the timing belt on mine the area was bone dry.

  4. #4
    Regular Member TimTay's Avatar
    Join Date
    Nov 2010
    Location
    BRECHIN
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My inlaws was covered in metal fileings aswell. Assume this is not a good thing. But he's still getting hassle with his running rough and showing a code for the sensor.

  5. #5
    Regular Member
    Join Date
    Jun 2007
    Location
    leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok thanx for the quick replies i will cancel the sparky ( for now )

    and get it into the garage

  6. #6
    Regular Member
    Join Date
    Jun 2007
    Location
    leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok got it into the garage and the machanic said the crank shaft sensor sits in the enguine block
    it will have oil in it

    so ive rebooked the sparky

    this ir turning into a nightmare

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. crankshaft sensor
    By liam8282 in forum Engine & Drivetrain
    Replies: 19
    Last Post: 18th September 2011, 13:29
  2. Crankshaft sensor
    By Dimscreen in forum Engine & Drivetrain
    Replies: 1
    Last Post: 19th April 2011, 10:27
  3. crankshaft sensor
    By morri76 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 24th April 2010, 20:36
  4. crankshaft sensor on v6
    By hugh in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 11th June 2009, 15:58
  5. Crankshaft Sensor
    By rhodod in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 4th December 2008, 23:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •