User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Spanner light - no codes

  1. #1
    New Member
    Join Date
    May 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner light - no codes

    Hi

    Car: 2005 Vectra 1.9 CDTI 150 SXI

    Miles: 105K

    Issue: light on dash (spanner over car)

    I have scanned the car with my diagnostic lead and there are no codes.

    One other thing I have noticed is that the car is slightly slow to start up, but drives perfectly fine.

    Any advice gladly recieved

    Thanks

  2. #2
    New Member
    Join Date
    Mar 2011
    Location
    stirling
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi i had the same problem with mine it would onluy show up on tech 2 or a bosh system, also had the slow to start , mine was the woodroof key on the crank pulley, its an easy fix ,i think the garage are charging me around 300 all in, but it made it like new again, just watch mine is a left hand thread and the first garage snaped bolt cos they were turning it wrong way

  3. #3
    New Member
    Join Date
    May 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds complicated

  4. #4
    New Member
    Join Date
    Mar 2011
    Location
    stirling
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its not complicated really just get a good garage to replace the bottom crank pulley but make sure they have the proper timing tools, if not it all looks good but is still 2 teeth out, when its plugged in it will come up with cam sensor fault, i changed mine 2 times before they found out it was the crank pulley woodruff key

  5. #5
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by dickybow View Post
    Issue: light on dash (spanner over car)
    Can you confirm this as the fault light has a spanner going vertically through the car, not a spanner over the car symbol.

  6. #6
    New Member
    Join Date
    May 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Big spanner standing up straight in front a symbol of the car. Goes out after 3 mins of driving.

    Thanks for all your help

  7. #7
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    One or more glowplugs are faulty would be my guess.

  8. #8
    Regular Member daveypower's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Dave View Post
    One or more glowplugs are faulty would be my guess.
    +1 on that dave

  9. #9
    New Member
    Join Date
    May 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Interesting because in the morning the glowplug light extinguishes after a second like any other diesel and during the day it barely blinks on ignition - to me thats a good sign !?

    On my old Merc C220 CDI, the glowplug light stayed on for a good 5 minutes to signify they needed changing.

    Cheers!

  10. #10
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    deffo glow plugs... try turning the key on and off a few times to bring the plugs on for longer before starting... until you get round to changing the plugs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 0
    Last Post: 26th August 2012, 03:15
  3. Spanner light no codes
    By DHobbs in forum Engine & Drivetrain
    Replies: 6
    Last Post: 5th April 2012, 12:05
  4. No codes being displayed - Spanner light
    By Ant SRi in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 6th September 2011, 22:41
  5. Spanner light/limp home/fault codes?
    By Factory Pilot in forum Engine & Drivetrain
    Replies: 2
    Last Post: 17th June 2009, 09:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •