User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: slight lack of power

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default slight lack of power

    hi all i have just bought a vectra c 2.2 dti 52 plate. a friend of mine has 56 plate 1.9 120 sri that beats mine hands down. so i had a go and his seems to boost at 2000rpm and mine picks up just after but then feel the bosst at just under 3000 rpm any body with idea why this is has my turbo been ajusted or is there a common fault thankyou all those try and do help

  2. #2
    Regular Member
    Join Date
    Mar 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    anybody able to help

  3. #3
    Regular Member daveypower's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    JAY excate same problem as your for ages, i adjusted my rod on the actuator, when i put it up to high by shortening it it went into safe mode, when i put it longer by reducing the boost the low down pull dissaperd and i got a slap of boost around 2800, so id would start by adjusting it in small increases, but if your having a race with your mate from a 2ND gear pull then you havent a hope, his is a 6spd box so if hes in 3rd you should be in 2nd etc. other things that have helped my 2.2 is cleaning the inlet elbow, the boost sensor, egr valve, i changed air filter, fuel filter, and did the air box mod, also sprayed 10k boost into her.

  4. #4
    Regular Member
    Join Date
    Mar 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    aye hoping to have a good clean and service her soon and ill try little adjustmeant like you say trial and error what worst that can happen with little turns limp mode

  5. #5
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mokka

    Trim : SE - Orange Rock 's !!

    Engine : 1.7CDTi

    Year : 2014

    Default

    Quote Originally Posted by daveypower View Post
    is cleaning the inlet elbow, the boost sensor, egr valve,
    As Davey said, plus clean the Inlet manifold. I did'nt remove mine, just removed the inlet piece (with the Rubber tube going to it from the intercooler, 4 bolts) then cleaned around as best i could with a vacuum cleaner and narrow piece of tube.
    A bottle brush plus carb cleaner would have helped as well.
    I then sprayed carb cleaner in there, put it back together and started it.
    Goes better now, but would probably be worth doing it properly by removing the inlet manifold.
    HTH's

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 120 Lack of power.
    By carling in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th January 2013, 19:25
  2. Lack of power
    By McLovinH in forum Engine & Drivetrain
    Replies: 20
    Last Post: 23rd August 2012, 22:17
  3. lack of power
    By scottaa73 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 8th May 2012, 10:49
  4. lack of power
    By dods in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 2nd July 2010, 20:33
  5. lack of power and EML
    By stevie b in forum Engine & Drivetrain
    Replies: 6
    Last Post: 7th June 2010, 09:43

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •