User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: 2.2 Dti No power and lots of noise

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    confused 2.2 Dti No power and lots of noise

    I need some urgent help please.

    Went to pull away from a set of lights just now and there was a loud hissing/sucking and rattling noise and absolutely no power. Foot down results in a slow climb to about 25mph and simply wont go above that.

    The noise doesnt seem to appear with the car in neutral or drive so I cant replicate the noise without actually driving.

    Im hoping a pipe has split or come off but its hard to check under the car at the side of the road.

    There are no warning lights on the dash.

    Anyone any idea please as its over 60 miles to get home.

  2. #2
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Also lots of white smoke out the exhaust when revving the engine.

  3. #3
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar S-Type V6

    Trim : Sport

    Engine : Petrol

    Year : 2003

    Default

    Quote Originally Posted by chrislloydie View Post
    Also lots of white smoke out the exhaust when revving the engine.
    White smoke could be injectors. Check for splits in your vacuum pipes.
    If the white smoke is ‘steam’ than it is almost certainly a head gasket blown – allowing water to seep into the engine to get ‘boiled’ or worse – a cracked cylinder head!
    Steam will dissipate rapidly being once it hits lower temperature ambient air while smoke will persist and hang in the air.

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Sounds like your turbo is dead mate. Better get it checked asap.

  5. #5
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Its definitaley white smoke and not steam. It hangs in the air and smells.

    I replaced the vaccuum hoses about 6 months ago with silicone ones but will check them anyway.

    Im dreading Turbo failure as I really cant afford to replace it at the moment and do 120 mile round trip to work and back every day so need the car.

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check yor intercooler hoses. Three on the top and 2 u shaped ones under the car either side of the intercooler. They could have a split in them or if you pulled away with a heavy foot a jubalee clip could have slipped on a hose and end could have come off. Was there a pop noise like a tyre bursting? If so that's a hose coming off!

  7. #7
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar S-Type V6

    Trim : Sport

    Engine : Petrol

    Year : 2003

    Default

    Quote Originally Posted by Celes View Post
    Sounds like your turbo is dead mate. Better get it checked asap.
    Yip could well be. I hope not but with the rattle noise you mention..

  8. #8
    Regular Member
    Join Date
    Sep 2009
    Location
    belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same with mine just before easter..... no power, thick white smoke and a rattle..... turbo shaft broken (poor quality oil or oil pump to blame turbo man reckons)... recon turbo £330 havent had it bed in yet as have been too sick to drive over the bank hol weekends... called the aa and have breakdown repair insurance.. hope the cover it tomorrow as the work was done and they werent rang by garage and everytime i called couldnt get through or office closed for bank holiday!!!!!

  9. #9
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Just a quick update, had it in a friends garage and he confirmed the turbo was knackered.

    Ordered a brand new vauxhall turbo through a friend in the trade for £275 plus vat and also ordered the gaskets. My mate is gonna fit the turbo and do a service on the car for £150. This cost also included recovering the car to his garage on a flatbed as it's an Auto so can't really be towed.

    Should be ready Monday, fingers crossed everything goes well.

  10. #10
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Car is running fine again now. Total cost was £540. This included vehicle recovery, new turbo and gaskets, air filter, oil and oil filter and all labour.

    Car was giving out a bit of smoke for a couple of days but was told that this was just burning oil in the exhaust from where turbo had failed. Used a bit of redex and the smoke is gone now.

    Thanks for all your advice guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 21st September 2012, 17:41
  2. Lots of warning lights + loss of power steering
    By Sparky67 in forum Troubleshooting
    Replies: 14
    Last Post: 29th March 2012, 10:38
  3. 1.9CDTI (120) popping noise then lots of white smoke
    By ali06 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 30th October 2009, 00:34
  4. Replies: 12
    Last Post: 9th April 2007, 01:20
  5. power steering noise ?
    By shillbag in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 6th October 2006, 16:33

Visitors found this page by searching for:

no power and noise vectra c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •