User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: K&N Air Filter on Vectra C Has Oil Sploshes ? Normal?

  1. #1
    Regular Member Elahi_786's Avatar
    Join Date
    Oct 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation K&N Air Filter on Vectra C Has Oil Sploshes ? Normal?

    Hi EveryOne, Hope your having a good Long Weekend.


    I opened my Vectra C 1.9 CDTI 150 to find the K&N Air Filter has Oil sploshes on it after purchasing it around 4-6 months ago, The original I replaced also had the same. Is this normal ???? if not what could be the cause and some help to direct me to doing it?

    Thanks
    E

  2. #2
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would take it out and put a new standard paper one back in. I fitted one on my vxr had it in for 2 days and the oild from the filter started messing with the MAF and it idled like a bag of spanners and quickly whipped it out and put the original back in.

  3. #3
    Regular Member jimmyred's Avatar
    Join Date
    Dec 2010
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Elahi_786 View Post
    ..... The original I replaced also had the same.
    This would seem to indicate the K&N is not at fault in this instance. Perhaps the air intake is contaminated? Its hard to see where else oil could be coming from. Which side of the filter is splattered? Could it concieveably be mud that has got sucked in somehow?
    Byebyeitssgsi, did returning to a paper filter solve the MAF problems? And was your K&N a brand new one? On their website they say that the only time it can cause problems is if it is reoiled too generously. They would say that tho wouldn't they?
    I'm not disputing what happened with yours, just interested to know if there were anything unusual that could have caused your problem.
    I've got one in myself, and like many people not had any problem with mine, but obviously keen to know what to watch out for.

  4. #4
    Regular Member jimmyred's Avatar
    Join Date
    Dec 2010
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Although reading your post again it maybe that vxrs give the k&n too much of a workout! I imagine they suck air a bit faster than my humble 1.8!

  5. #5
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah it was brand new mate. To be honest the guys on vxr online told me i might aswell stick with the standard filter and spend the £40 on fuel lol. I had one on my old gsi and never had a problem but your probably correct with the vxr pulling in much more air and it has been said before over on vxr online that oiled panel filters are MAF killers.

    Yes the standard filter corrected the problem so the k&n will be living in the garage from now on.

  6. #6
    Regular Member jimmyred's Avatar
    Join Date
    Dec 2010
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    makes sense. If my MAF ever plays up, i'll know where to start. I kept my old paper filter as it was quite new, even though only a fiver.

  7. #7
    Regular Member Elahi_786's Avatar
    Join Date
    Oct 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation Reply

    After reading your guys replies, The Original genuine paper air filter that was in their first also had the same problem. When I removed it had oil / fuel / crap thats black on it. THE SO CALLED Oil is on the back of the filter on both occasions.

    I checked the MAF and the whole box and all the pipes there all clean and well no oil or wetness anywhere.


    THE FILTER WAS ALSO BRAND NEW



    Last edited by Elahi_786; 1st May 2011 at 22:55. Reason: Added new Data

  8. #8
    Regular Member jimmyred's Avatar
    Join Date
    Dec 2010
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    that is odd...theres only two places it could be coming from really: the intake or the MAF end. If you aren't having any mechanical problems or any OBD codes stored, the only thing to do would be keep an eye on it make sure it doesn't get worse. As above, the worry is the MAF getting contaminated, but that would generate warning light/error codes. I believe MAF can be cleaned if this does happen.
    Perhaps see if it happens more in wet weather, or on motorway...see if any pattern shows up, might help get to bottom of it. Sorry not to be more help, but thats what I'd do.

  9. #9
    Regular Member Elahi_786's Avatar
    Join Date
    Oct 2010
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation

    No error message and car goes in for a regular health check once in a while in between services & it had one a few weeks ago and came back with a few minor faults such as aux belt will need changing in due time.

    thats it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Making a normal Vectra an XP2?
    By hog in forum Styling
    Replies: 27
    Last Post: 24th October 2012, 21:37
  2. Vectra - Both Wipers not working on Intermient/normal speed???
    By MK SRIVECTRA in forum Engine & Drivetrain
    Replies: 1
    Last Post: 2nd June 2012, 03:08
  3. Hi all clutch vibration on a vectra is this normal
    By borderman932 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 21st February 2012, 01:02
  4. Is this normal.....oil in the air filter intake
    By killer_bunny in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 25th February 2010, 09:12
  5. k+n filter for vectra c
    By vectra 2.0 t in forum Parts for sale
    Replies: 7
    Last Post: 29th August 2006, 21:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •