User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: P0400 - EGR Flow Malfunction

  1. #1
    Regular Member
    Join Date
    Apr 2011
    Location
    Workington, Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default P0400 - EGR Flow Malfunction

    Just read the fault code on my car and it came up with the above. It's a brand new valve that's been fitted. Is it just an old fault code that hasn't been erased? If not what could be the problem?

    Spanner light only stays on the dash when engine is cold for a couple mins which I found out to be a faulty glow plug, in process of changing.

    Any ideas lads?

  2. #2
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    I think you've answered it, if you have a new EGR, then the EGR code is likely to be regarding the old one.

  3. #3
    Full Member bobssignum's Avatar
    Join Date
    Dec 2007
    Location
    polishing something or other somewhere
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum 2.0 DTi

    Trim : Elegance/Elite

    Engine : 2.0DTi

    Year : 2003

    Mileage : 73350

    Default

    With a new egr fitted i expect it to be a old fault code that should clear after 25 starts , then again it may be that the electric connection has not clicked home properly ,i once had an egr fault appear after cleaning my egr it turned out to be the electrical connection had been twisted the wrong way and was stretching the wire,s
    Driving vauxhall,s for 30 + years
    and still loving it

  4. #4
    Regular Member
    Join Date
    Apr 2011
    Location
    Workington, Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Right, thanks pal. I'll clear the code and see what happens.

  5. #5
    Regular Member
    Join Date
    Dec 2007
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you get it fixed?

  6. #6
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Quote Originally Posted by jtg View Post
    Did you get it fixed?
    Any luck with this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0400 - Exhaust Gas Recirculation Flow Insufficient Detected
    By lencuff in forum Y & Z30DT Specific
    Replies: 5
    Last Post: 20th November 2012, 18:15
  2. Exhaust gas recirc flow prob P0400?
    By NPS in forum Engine & Drivetrain
    Replies: 2
    Last Post: 16th July 2011, 05:35
  3. P0400-F8 Exhaust Gas Recirculation Valve Feedback Signal Malfunction
    By Vectra Forever in forum Engine & Drivetrain
    Replies: 12
    Last Post: 30th June 2011, 15:19
  4. P0400-5B Exhaust Gas Recirculation Flow Excessive Detected
    By zafira in forum Diesel Engine related
    Replies: 4
    Last Post: 11th September 2010, 07:46
  5. Exhaust Gas Recirculation Flow Malfunction
    By H0885 in forum Vectra C / Signum Troubleshooting
    Replies: 31
    Last Post: 20th January 2009, 20:20

Visitors found this page by searching for:

vectra p0400 egr malfunction

vectra egr flow malfunction code

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •