User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Emissions light after EGR removal

  1. #1
    New Member
    Join Date
    Jan 2011
    Location
    Huntingdon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Emissions light after EGR removal

    Hi all,

    I have a 2006 1.9 cdti and decded to clean the EGR. After tsking it off it appears it is quite new (April 2010) and didn't need cleaning.
    After putting it back on and going for a drive I got the spanner light.
    Stopped the car and restarted and it has now gone but has been replaced with the emissions light.
    Fuel economy is fine as is the performance, what can I do to next?
    Tried to find the fault code using the pedals procedure but nothing happened, no flashing lights.

  2. #2
    Regular Member
    Join Date
    Sep 2008
    Location
    Antwerp, Belgium
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by gr1340 View Post
    Hi all,

    I have a 2006 1.9 cdti and decded to clean the EGR. After tsking it off it appears it is quite new (April 2010) and didn't need cleaning.
    After putting it back on and going for a drive I got the spanner light.
    Stopped the car and restarted and it has now gone but has been replaced with the emissions light.
    Fuel economy is fine as is the performance, what can I do to next?
    Tried to find the fault code using the pedals procedure but nothing happened, no flashing lights.

    i uses once a special product for cleaning the intake and egr (provided by the official garage) and immediately the exhaust light came on too.

    car ran perfect as before and after resetting via tech2 it came back 2 days later.
    only thing that helped was new egr valve

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Did you use a new gasket when re-fitting the EGR? If not, the old one might not have sealed properly. Also, check the contacts on the connector that plugs into it

    Alternatively, blank off the EGR completely, and get the ECU remapped to remove teh EGR from it completely, thus putting the warning lights out.

  4. #4
    New Member
    Join Date
    Jan 2011
    Location
    Huntingdon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good point about the gasket, I will check that this afternoon. Thank you

  5. #5
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Did you plug it back in/properly? Or it sounds like the valve me be jammed in the closed position. Have a couble check and also replace the gaskets for all they cost.

    Gazza4

  6. #6
    Regular Member
    Join Date
    Jun 2009
    Location
    Dover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same thing.After replacing EGR with the new one I had no lights on the dash and car was fine.Then I put a foot down as I was chasing my mate and light come on.I thought that some bolts could be undone,but when I removed the engine cover I found that plug just unclipped itself that's why car was fine even with emission light on

  7. #7
    Regular Member
    Join Date
    Jan 2010
    Location
    Perkinsville, County Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : Sri nav

    Engine : Z19dth

    Year : 2006

    Default

    Something similar happened to mine, so the plug is now zip tied in place.

  8. #8
    Regular Member
    Join Date
    Jan 2010
    Location
    Perkinsville, County Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : Sri nav

    Engine : Z19dth

    Year : 2006

    Default

    Hasn't there been talk of some EGR valves that needed vauxhall to do something with the ecu to make the car accept them?

  9. #9
    New Member
    Join Date
    Jan 2011
    Location
    Huntingdon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Update - emissions light was off today so hopefully it was just a false alarm.

    I was going to take it off again and check the gasket next weekend but won't bother now.

    Thank you for your help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emissions light
    By shuggler in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 16th June 2012, 19:16
  2. Emissions Light
    By battle84555 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 20th February 2011, 19:56
  3. Emissions light on!!!
    By Bad Ad in forum Engine & Drivetrain
    Replies: 10
    Last Post: 16th January 2011, 22:37
  4. Emissions Light
    By MultiDropper in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 24th December 2010, 23:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •