User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Oil in Water on Z20NET Engine

  1. #1
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Oil in Water on Z20NET Engine

    Hi Folks

    Driving back from work tonight, noticed hot oily smell when stationary at lights. Anyway got home, lifted the bonnet - expansion water bottle full of oily mayonaise and under some pressure, oil level right down but no mayonaise in oil.
    What does the team think before I start dismantling - head gasket, oil cooler or turbo ?

    Many Thanks in advance
    SJ

  2. #2
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    Hi sjanisz
    you say cooling system under some pressure but if engine was hot the cooling system is a pressurized system,you need to have a pressure test done or a snif test to check for head gasket failure,but sounds like it may be oil cooler failure,as oil pressure is higher than coolant pressure oil will transfer into cooling system.

  3. #3
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 110000

    Default

    Quote Originally Posted by jonnybravo View Post
    Hi sjanisz
    you say cooling system under some pressure but if engine was hot the cooling system is a pressurized system,you need to have a pressure test done or a snif test to check for head gasket failure,but sounds like it may be oil cooler failure,as oil pressure is higher than coolant pressure oil will transfer into cooling system.
    Is the oil cooler not an external one on a NET like the Z22SE (VX220) or is it water cooled a la V6?

  4. #4
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oil cooler to my knowledge is bolted on at side of the engine next to oil filter
    SJ

  5. #5
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thank you all for your help, can't do anything tomorrow as I'm working but will start the clean up on Saturday and let you know of my progress.
    What is the best thing to get the oil out of the hoses etc ? A colleague recommended biological washing powder.

    Thanks again

    SJ

  6. #6
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well finally got back from working away and started the investigation,
    Disconnected the water pipes from the oil cooler, topped up engine oil, started the engine - oil oozing out in copious amounts out of water connections to oil cooler - - off to dealers tommorrow (if they are open ) to get a new cooler.
    Hopefully oil cooler + 'O' rings cheaper than head gasket + associated labour.

    SJ

  7. #7
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hope it all goes okay!

  8. #8
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Have you thought of using second hand??..megavox in nottm(sandiacre) are personaly recommended..

  9. #9
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Guys,
    Will let you know the end result - what I am not looking forward to is the massive engine degrease and getting all the oil out of the water works (big can of jizer on the shopping list me thinks)
    SJ

  10. #10
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well the new oil cooler went on easy enough (wallet's a bit lighter as well!). But can I get the goo out of the water ways - if you pardon the inuendo I've stuck my hosepipe into every conceivable orifice and waited until the water ran clear but it looks like the water pump has a coating of goo as the water is just not circulating resulting in hot spots (and steam !).
    Does anyone know if there is a water pump / engine block drain plug on these things ?
    Thanks
    SJ

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 7th December 2010, 21:48
  2. edt100 water pump (z20net)
    By mat100edt in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th September 2009, 18:24

Visitors found this page by searching for:

z20net oil pressure check

z20net water pump drain plug leaking

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •