User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: ongoing CC problems

  1. #1
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default ongoing CC problems

    Chaps,

    My cruise control is knackered. Keeps cutting out on my and sometimes won't come back on. Did some searching on here and so far I've replaced the stalk and the clutch pedal spring, still no joy. I'm thinking the next step would be the clutch switch since I'm not aware of a problem with the brake switch since the brake lights seem to work fine. Does this seem a reasonable next step?

    Anything I've missed or anyone have any other suggestions?

    Cheers

  2. #2
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Seeing as you'll be under there, it might be worth changing them both on spec mate - clutch switch definitely next step but depending on price get them both done...

  3. #3
    Regular Member
    Join Date
    May 2008
    Location
    Tyneside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Think there are two contacts in the brake switch, one for lights and one for CC, so might be worth replacing. Alternatively could try switch with a meter. HTH

  4. #4
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have similar issues mate, mine works intermittantly

    Was the spring / stalk hard to change ?

  5. #5
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    stalk very easy, takes 10 secs. Pull old stalk out, shove in new one. Spring was easy too. A bit of a pain to get old one out but 2 mins to put new one in.

  6. #6
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Knox View Post
    stalk very easy, takes 10 secs. Pull old stalk out, shove in new one. Spring was easy too. A bit of a pain to get old one out but 2 mins to put new one in.
    Sooooooooooooooooooooooooooooooooooooo

    Where are the HOW 2's

  7. #7
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    I thought you had to slide a paperclip down the side of the stalk through a small hole to release the locking clip?

  8. #8
    Regular Member luke.oldham's Avatar
    Join Date
    Aug 2009
    Location
    manchester/stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my clutch does'nt have a spring under it,if i bought one would it be a direct fit coz im having trouble with my cc when i lift the pedal up it stays on.p.s were can i get one and how much. cheers

  9. #9
    Regular Member
    Join Date
    May 2008
    Location
    Tyneside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by luke.oldham View Post
    my clutch does'nt have a spring under it,if i bought one would it be a direct fit coz im having trouble with my cc when i lift the pedal up it stays on.p.s were can i get one and how much. cheers
    Here's a link with part no price and piccies http://www.vectra-c.com/forum/showth...=clutch+spring

  10. #10
    Regular Member luke.oldham's Avatar
    Join Date
    Aug 2009
    Location
    manchester/stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tridley View Post
    Here's a link with part no price and piccies http://www.vectra-c.com/forum/showth...=clutch+spring
    thats spot on mate,thanks for that.cheers. luke

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ongoing additions
    By triple595 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 5th April 2011, 20:25
  2. Z22YH Problems Ongoing??
    By Mr_Chips78 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 6th November 2010, 17:34
  3. Ongoing problem - P0340
    By Ste in forum Engine & Drivetrain
    Replies: 5
    Last Post: 4th December 2009, 13:01
  4. My ongoing leak saga...
    By TrevF in forum Bodywork & Interior
    Replies: 2
    Last Post: 10th March 2009, 12:31
  5. Ongoing saga
    By v6boy in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 7th August 2006, 19:26

Visitors found this page by searching for:

vectra cc problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •